summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAliaksei Urbanski <aliaksei.urbanski@gmail.com>2024-07-03 00:13:50 +0300
committerMarc Schiffbauer <mschiff@gentoo.org>2024-07-09 15:46:56 +0200
commit9a13411a940d9e2b93bd08fb82b3e40497016df2 (patch)
tree7ccd00d0711933de61b726667960cc3766904856 /net-p2p
parentapp-portage/gemato: depend on gnupg[ssl] too (diff)
downloadgentoo-9a13411a940d9e2b93bd08fb82b3e40497016df2.tar.gz
gentoo-9a13411a940d9e2b93bd08fb82b3e40497016df2.tar.bz2
gentoo-9a13411a940d9e2b93bd08fb82b3e40497016df2.zip
net-p2p/syncthing: add 1.27.9
Release: - https://github.com/syncthing/syncthing/releases/tag/v1.27.9 These changes also: - add the repository url to the HOMEPAGE variable - update the minimal go version - switch back to the older version of the tests_race patch - refactor src_prepare a little bit Signed-off-by: Aliaksei Urbanski <aliaksei.urbanski@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/36748 Signed-off-by: Marc Schiffbauer <mschiff@gentoo.org>
Diffstat (limited to 'net-p2p')
-rw-r--r--net-p2p/syncthing/Manifest1
-rw-r--r--net-p2p/syncthing/syncthing-1.27.9.ebuild114
2 files changed, 115 insertions, 0 deletions
diff --git a/net-p2p/syncthing/Manifest b/net-p2p/syncthing/Manifest
index ade5a735642d..aaa9fe33d59e 100644
--- a/net-p2p/syncthing/Manifest
+++ b/net-p2p/syncthing/Manifest
@@ -1,3 +1,4 @@
DIST syncthing-1.27.2.tar.gz 14967954 BLAKE2B 8f033e18679f7accc3d461566da88fa45b2e1c8dc1b1b5ace2732e3987d82e8d458c42dc3571f7d1199cf35667be72fcf81b65efa9cd2dac65297bc86b03e284 SHA512 6b6bd57268b32b5db2377cf813229de978e26de606ac3bf2b515ddb35fd8131fafdb88abbfac1cb7d0f443224538cca7a6eba64f4bd737135f5a1c98e76439f9
DIST syncthing-1.27.6.tar.gz 15147926 BLAKE2B 63003b95f0458ece86aeeff8871ebe591f31ffda713427a7ded9d852a38770514143119983d3b28e82fe570992e1a35b9bcdb5d268fa5d3b4d23073edc2e811b SHA512 2dbffd6002d557cc7ec3beab10d00f0e531d71ba60ed75fc20fd49f3d0c79b28197ed1c6795ef42717d12b8f4f594d1cadc8a67d0925f7f7f1cd20d1baa6edae
DIST syncthing-1.27.8.tar.gz 15305526 BLAKE2B f3458792f474f661e5420058d9c2991d04b74f5414b8e23c8c8e140e96ac45c7dea72017e3d1349cd8ef3b6a22a64b41f171ba3ac2bdf436a9a3460673ec201d SHA512 9f2d8cd70a8b269553919be07b63cb5dc9e83fe761596a1e1012339b10733f9619b35c532d66b8be1dc1a0888373308b1b6dab0f895c81e994d66c942734cbe6
+DIST syncthing-1.27.9.tar.gz 15394317 BLAKE2B a7b02c57d897c3fc56734d039e5cf0eceaf802258e3a9fd34d667a9e22ff75db0bd1cf6b8d5be8b8e9d4eb772145222bee7d3154b004c437bbab23f33fb98e66 SHA512 11c56dcf3b44f87581560b4f8f8f76d6ee851fc0421d85f458a32c3900bd0ee6bb2964b7d5253a343d61ba57e3aa40f2f8a94d6f5d5d5b0cf27dc1cc28a14fa1
diff --git a/net-p2p/syncthing/syncthing-1.27.9.ebuild b/net-p2p/syncthing/syncthing-1.27.9.ebuild
new file mode 100644
index 000000000000..d45dff50f667
--- /dev/null
+++ b/net-p2p/syncthing/syncthing-1.27.9.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop go-module systemd xdg-utils
+
+DESCRIPTION="Open Source Continuous File Synchronization"
+HOMEPAGE="https://syncthing.net https://github.com/syncthing/syncthing"
+SRC_URI="https://github.com/${PN}/${PN}/releases/download/v${PV}/${PN}-source-v${PV}.tar.gz -> ${P}.tar.gz"
+
+S="${WORKDIR}"/${PN}
+
+LICENSE="Apache-2.0 BSD BSD-2 CC0-1.0 ISC MIT MPL-2.0 Unlicense"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="selinux tools"
+
+RDEPEND="acct-group/syncthing
+ acct-user/syncthing
+ tools? ( >=acct-user/stdiscosrv-1
+ >=acct-user/strelaysrv-1 )
+ selinux? ( sec-policy/selinux-syncthing )"
+BDEPEND=">=dev-lang/go-1.21.0"
+
+DOCS=( README.md AUTHORS CONTRIBUTING.md )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.4-TestIssue5063_timeout.patch
+ "${FILESDIR}"/${PN}-1.18.4-tool_users.patch
+ "${FILESDIR}"/${PN}-1.23.2-tests_race.patch
+)
+
+src_prepare() {
+ # Bug #679280
+ xdg_environment_reset
+
+ default
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/stdiscosrv|' \
+ cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service \
+ || die
+ sed -i \
+ 's|^ExecStart=.*|ExecStart=/usr/libexec/syncthing/strelaysrv|' \
+ cmd/strelaysrv/etc/linux-systemd/strelaysrv.service \
+ || die
+}
+
+src_compile() {
+ GOARCH= go run build.go -version "v${PV}" -no-upgrade -build-out=bin/ \
+ ${GOARCH:+-goarch="${GOARCH}"} \
+ build $(usex tools "all" "") || die "build failed"
+}
+
+src_test() {
+ go run build.go test || die "test failed"
+}
+
+src_install() {
+ local icon_size
+
+ doman man/*.[157]
+ einstalldocs
+
+ dobin bin/syncthing
+
+ domenu etc/linux-desktop/*.desktop
+ for icon_size in 32 64 128 256 512; do
+ newicon -s ${icon_size} assets/logo-${icon_size}.png ${PN}.png
+ done
+ newicon -s scalable assets/logo-only.svg ${PN}.svg
+
+ systemd_dounit etc/linux-systemd/system/${PN}{@,-resume}.service
+ systemd_douserunit etc/linux-systemd/user/${PN}.service
+ newconfd "${FILESDIR}"/${PN}.confd ${PN}
+ newinitd "${FILESDIR}"/${PN}.initd-r2 ${PN}
+
+ keepdir /var/log/${PN}
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/${PN}.logrotate ${PN}
+
+ insinto /etc/ufw/applications.d
+ doins etc/firewall-ufw/${PN}
+
+ if use tools; then
+ exeinto /usr/libexec/syncthing
+ local exe
+ for exe in bin/* ; do
+ [[ "${exe}" == "bin/syncthing" ]] || doexe "${exe}"
+ done
+
+ systemd_dounit cmd/stdiscosrv/etc/linux-systemd/stdiscosrv.service
+ newconfd "${FILESDIR}"/stdiscosrv.confd stdiscosrv
+ newinitd "${FILESDIR}"/stdiscosrv.initd-r1 stdiscosrv
+
+ systemd_dounit cmd/strelaysrv/etc/linux-systemd/strelaysrv.service
+ newconfd "${FILESDIR}"/strelaysrv.confd strelaysrv
+ newinitd "${FILESDIR}"/strelaysrv.initd-r1 strelaysrv
+
+ insinto /etc/logrotate.d
+ newins "${FILESDIR}"/stdiscosrv.logrotate strelaysrv
+ newins "${FILESDIR}"/strelaysrv.logrotate strelaysrv
+ fi
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}