summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2020-08-03 12:59:21 -0400
committerRick Farina <zerochaos@gentoo.org>2020-08-03 12:59:32 -0400
commitdbca9ca3143530ca142defc5e198e722ac7cb377 (patch)
tree247e6a8a10152319bdc6439bc2764076f6393092 /net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild
parentwww-client/dillo: drop keywords down to ~hppa (diff)
downloadgentoo-dbca9ca3143530ca142defc5e198e722ac7cb377.tar.gz
gentoo-dbca9ca3143530ca142defc5e198e722ac7cb377.tar.bz2
gentoo-dbca9ca3143530ca142defc5e198e722ac7cb377.zip
net-wireless/kismetmobiledashboard: remove python references
Package-Manager: Portage-3.0.1, Repoman-2.3.23 Signed-off-by: Rick Farina <zerochaos@gentoo.org>
Diffstat (limited to 'net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild')
-rw-r--r--net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild
new file mode 100644
index 000000000000..40806893ce61
--- /dev/null
+++ b/net-wireless/kismetmobiledashboard/kismetmobiledashboard-1.5_beta1-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Mobile UI for kismet"
+HOMEPAGE="https://github.com/elkentaro/KismetMobileDashboard"
+if [ "${PV}" = "9999" ]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/elkentaro/KismetMobileDashboard.git"
+else
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+ SRC_URI="https://github.com/elkentaro/KismetMobileDashboard/archive/V1.5-beta.1.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/KismetMobileDashboard-1.5-beta.1"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="net-wireless/kismet"
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+src_compile() {
+ KIS_SRC_DIR="/usr/share/kismet" emake
+}
+
+src_install() {
+ DESTDIR="${ED}" KIS_SRC_DIR="/usr/share/kismet" emake install
+}