summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Mayo <aklhfex@gmail.com>2024-12-02 19:22:05 +0000
committerSam James <sam@gentoo.org>2024-12-26 10:24:42 +0000
commit1aea28cd422c7248bc81d8aec6b43c578c26315e (patch)
treee313b5deb1912bf10f619274ec7141adc76b42e2 /sci-geosciences
parentsci-geosciences/gpsbabel: Rename xmldoc patch (diff)
downloadgentoo-1aea28cd422c7248bc81d8aec6b43c578c26315e.tar.gz
gentoo-1aea28cd422c7248bc81d8aec6b43c578c26315e.tar.bz2
gentoo-1aea28cd422c7248bc81d8aec6b43c578c26315e.zip
sci-geosciences/gpsbabel: Fix always checking for GUI dependencies
Closes: https://bugs.gentoo.org/945696 Signed-off-by: Chris Mayo <aklhfex@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/39570 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sci-geosciences')
-rw-r--r--sci-geosciences/gpsbabel/gpsbabel-1.9.0-r1.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/sci-geosciences/gpsbabel/gpsbabel-1.9.0-r1.ebuild b/sci-geosciences/gpsbabel/gpsbabel-1.9.0-r1.ebuild
index 9a35bba8963f..f7d3e1d947c9 100644
--- a/sci-geosciences/gpsbabel/gpsbabel-1.9.0-r1.ebuild
+++ b/sci-geosciences/gpsbabel/gpsbabel-1.9.0-r1.ebuild
@@ -69,6 +69,7 @@ src_prepare() {
rm -r shapelib zlib || die
use doc && cp "${DISTDIR}/gpsbabel.org-style3.css" "${S}"
+ use gui || sed -i -e '/add_subdirectory(gui)/d' CMakeLists.txt || die
}
src_configure() {
@@ -76,9 +77,6 @@ src_configure() {
-DGPSBABEL_WITH_LIBUSB=pkgconfig
-DGPSBABEL_WITH_SHAPELIB=pkgconfig
-DGPSBABEL_WITH_ZLIB=pkgconfig
- -DGPSBABEL_MAPPREVIEW=$(usex gui)
- -DGPSBABEL_EMBED_MAP=$(usex gui)
- -DGPSBABEL_EMBED_TRANSLATIONS=$(usex gui)
-DUSE_QT6=ON
)