summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2021-06-18 15:15:18 +0200
committerDavid Seifert <soap@gentoo.org>2021-06-18 15:15:18 +0200
commit44ed00b9182af2ef6d4bd448d2edf35c2128fdec (patch)
treedea9828fb8d74d0c095beecd632ce3ed9f493886 /sci-libs/libint/libint-2.6.0-r3.ebuild
parentsci-libs/givaro: Depend on dev-libs/gmp[cxx(+)] (diff)
downloadgentoo-44ed00b9182af2ef6d4bd448d2edf35c2128fdec.tar.gz
gentoo-44ed00b9182af2ef6d4bd448d2edf35c2128fdec.tar.bz2
gentoo-44ed00b9182af2ef6d4bd448d2edf35c2128fdec.zip
sci-libs/libint: Depend on dev-libs/gmp[cxx(+)]
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sci-libs/libint/libint-2.6.0-r3.ebuild')
-rw-r--r--sci-libs/libint/libint-2.6.0-r3.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/sci-libs/libint/libint-2.6.0-r3.ebuild b/sci-libs/libint/libint-2.6.0-r3.ebuild
new file mode 100644
index 000000000000..cf8dc7472d94
--- /dev/null
+++ b/sci-libs/libint/libint-2.6.0-r3.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools fortran-2 toolchain-funcs
+
+DESCRIPTION="Matrix elements (integrals) evaluation over Cartesian Gaussian functions"
+HOMEPAGE="https://github.com/evaleev/libint"
+SRC_URI="https://github.com/evaleev/libint/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="2"
+LICENSE="GPL-2"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs doc"
+
+DEPEND="
+ dev-libs/boost
+ dev-libs/gmp[cxx(+)]
+ doc? (
+ dev-texlive/texlive-latex
+ dev-tex/latex2html
+ )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-cxx=$(tc-getCXX) \
+ --with-cxx-optflags="${CXXFLAGS}" \
+ --with-cxxgen-optflags="${CXXFLAGS}" \
+ --with-cxxdepend=$(tc-getCXX) \
+ --with-ranlib=$(tc-getRANLIB) \
+ --with-ar=$(tc-getAR) \
+ --with-ld=$(tc-getLD) \
+ --enable-eri=2 --enable-eri3=2 --enable-eri2=2 \
+ --with-eri-max-am=7,5,4 --with-eri-opt-am=3 \
+ --with-eri3-max-am=7 --with-eri2-max-am=7 \
+ --with-g12-max-am=5 --with-g12-opt-am=3 \
+ --with-g12dkh-max-am=5 --with-g12dkh-opt-am=3 \
+ --enable-contracted-ints \
+ --enable-shared
+ $(use_enable static-libs static)
+}
+
+src_compile() {
+ emake LDFLAGS="${LDFLAGS}"
+
+ use doc && emake html pdf
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ DOCS=( doc/progman/progman.pdf )
+ HTML_DOCS=( doc/progman/progman/*.{html,png,css} )
+ einstalldocs
+ fi
+}