summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2016-03-16 04:41:21 +0600
committerAndrey Grozin <grozin@gentoo.org>2016-03-16 04:41:21 +0600
commitf28eecac3372b712b101ae741474a292c93bee7e (patch)
treec3d037d20b4a0a26c34ffd99f583d02e4b8c19d8 /sci-mathematics
parentdev-haskell/xhtml: allow ghc-7.10.3 (diff)
downloadgentoo-f28eecac3372b712b101ae741474a292c93bee7e.tar.gz
gentoo-f28eecac3372b712b101ae741474a292c93bee7e.tar.bz2
gentoo-f28eecac3372b712b101ae741474a292c93bee7e.zip
sci-mathematics/mathmod: initial import
Package-Manager: portage-2.2.28
Diffstat (limited to 'sci-mathematics')
-rw-r--r--sci-mathematics/mathmod/Manifest1
-rw-r--r--sci-mathematics/mathmod/mathmod-4.1.ebuild42
-rw-r--r--sci-mathematics/mathmod/metadata.xml22
3 files changed, 65 insertions, 0 deletions
diff --git a/sci-mathematics/mathmod/Manifest b/sci-mathematics/mathmod/Manifest
new file mode 100644
index 000000000000..8adff3ba4a00
--- /dev/null
+++ b/sci-mathematics/mathmod/Manifest
@@ -0,0 +1 @@
+DIST mathmod-4.1.src.zip 974709 SHA256 fff57e82fc57b90af98b345f14219c01b1709b019735739b9244173bec626ad4 SHA512 e7a170f5b57384cca4e755a0bb3691ec3fe29e9b22027534f1e84ed656905495c70eea8c69262f31a937ca508c34177d33adc23f5a8a3c91db1eceb2aa283a6d WHIRLPOOL ee68e96744cd210e727111677c4f7b57221f4754cf60218be980b31d482c1e9a24adaed853e098ad4f2a14ce8a8e1523c07121285746d23fc39035de18650fd1
diff --git a/sci-mathematics/mathmod/mathmod-4.1.ebuild b/sci-mathematics/mathmod/mathmod-4.1.ebuild
new file mode 100644
index 000000000000..74d1903d8db3
--- /dev/null
+++ b/sci-mathematics/mathmod/mathmod-4.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils qmake-utils fdo-mime
+
+DESCRIPTION="Plot parametric and implicit surfaces"
+HOMEPAGE="https://www.facebook.com/pages/MathMod/529510253833102"
+SRC_URI="mirror://sourceforge/${PN}/${P}.src.zip"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-qt/qtwidgets:5 dev-qt/qtopengl:5"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}-branches-274-trunk
+
+src_configure() {
+ eqmake5 MathMod.pro
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe MathMod
+ newicon -s 16 icon/catenoid_mini_16x16.png catenoid.png
+ newicon -s 32 icon/catenoid_mini_32x32.png catenoid.png
+ newicon -s 64 icon/catenoid_mini_64x64.png catenoid.png
+ make_desktop_entry MathMod MathMod catenoid
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+ fdo-mime_desktop_database_update
+}
diff --git a/sci-mathematics/mathmod/metadata.xml b/sci-mathematics/mathmod/metadata.xml
new file mode 100644
index 000000000000..1a5c54097fc1
--- /dev/null
+++ b/sci-mathematics/mathmod/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>grozin@gentoo.org</email>
+ <name>Andrey Grozin</name>
+</maintainer>
+<maintainer type="project">
+ <email>sci-mathematics@gentoo.org</email>
+ <name>Gentoo Mathematics Project</name>
+</maintainer>
+<longdescription lang="en">
+ MathMod is a mathematical modeling software that visualize and animate
+ implicit and parametric surfaces.
+ MathMod supports: 3D and 4D plotting and animation, OBJ output file format,
+ Textue and pigmentation support, Noise and Turbulence effects support,
+ Large set of scripted examples.
+</longdescription>
+<upstream>
+ <remote-id type="sourceforge">mathmod</remote-id>
+</upstream>
+</pkgmetadata>