summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 17:34:09 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-09 18:55:51 +0100
commit34c87461e60d34f97cd40b297065dcf612929ae7 (patch)
treeee9c6f13fcdb78c5a741fd32b91c2beb2eda61f5 /sys-apps/epoch/epoch-1.3.0.ebuild
parentkde-misc/tellico: Fix build with USE=-taglib (diff)
downloadgentoo-34c87461e60d34f97cd40b297065dcf612929ae7.tar.gz
gentoo-34c87461e60d34f97cd40b297065dcf612929ae7.tar.bz2
gentoo-34c87461e60d34f97cd40b297065dcf612929ae7.zip
sys-apps/epoch: EAPI-8 bump, fix postinst contact info
Bug: https://bugs.gentoo.org/783738 Closes: https://bugs.gentoo.org/809224 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'sys-apps/epoch/epoch-1.3.0.ebuild')
-rw-r--r--sys-apps/epoch/epoch-1.3.0.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/sys-apps/epoch/epoch-1.3.0.ebuild b/sys-apps/epoch/epoch-1.3.0.ebuild
index a37c2f912f6a..835ef3b7d1e0 100644
--- a/sys-apps/epoch/epoch-1.3.0.ebuild
+++ b/sys-apps/epoch/epoch-1.3.0.ebuild
@@ -1,33 +1,29 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=8
-inherit epatch linux-info
+inherit linux-info
-MY_PV="${PV/rc/RC}"
-MY_P="${PN}-${MY_PV}"
-
-DESCRIPTION="An init system, a /sbin/init replacement; designed for simplicity"
-HOMEPAGE="http://universe2.us/epoch.html"
-SRC_URI="http://universe2.us/${PN}_${PV}.tar.gz"
+DESCRIPTION="Init system, /sbin/init replacement; designed for simplicity"
+HOMEPAGE="https://universe2.us/epoch.html"
+SRC_URI="https://universe2.us/${PN}_${PV}.tar.gz"
+S="${WORKDIR}/${PN}_${PV/rc/RC}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-S="${WORKDIR}/${PN}_${PV}"
-
pkg_pretend() {
local CONFIG_CHECK="~PROC_FS"
[[ ${MERGE_TYPE} != buildonly ]] && check_extra_config
}
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
- epatch "${FILESDIR}"/${PN}-1.3.0-fix-main.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.0-fix-CFLAGS.patch
+ "${FILESDIR}"/${PN}-1.3.0-fix-main.patch
+)
src_compile() {
NEED_EMPTY_CFLAGS=1 sh ./buildepoch.sh || die "Cannot build epoch."
@@ -68,7 +64,7 @@ pkg_postinst() {
elog ""
elog "Additional information about epoch is available at"
elog "${HOMEPAGE} and configuration documentation at"
- elog "http://universe2.us/epochconfig.html which is useful reading material."
+ elog "https://universe2.us/epochconfig.html which is useful reading material."
elog ""
- elog "Its author Subsentient can be contacted at #epoch on irc.freenode.net."
+ elog "Its author Subsentient can be contacted at #epoch on irc.libera.chat."
}