summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2020-07-12 19:28:29 +0300
committerMikle Kolyada <zlogene@gentoo.org>2020-07-12 19:28:29 +0300
commita2edd45540aa5043b4d55375d7e91deb3eb6cb2f (patch)
tree8d025a9270b007ebd234aa5b193a9c0ee4dde349 /sys-apps/pcsc-tools
parentnet-dns/bind: remove more manpages (diff)
downloadgentoo-a2edd45540aa5043b4d55375d7e91deb3eb6cb2f.tar.gz
gentoo-a2edd45540aa5043b4d55375d7e91deb3eb6cb2f.tar.bz2
gentoo-a2edd45540aa5043b4d55375d7e91deb3eb6cb2f.zip
sys-apps/pcsc-tools: Version bump (v1.5.7)
Package-Manager: Portage-2.3.99, Repoman-2.3.23 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'sys-apps/pcsc-tools')
-rw-r--r--sys-apps/pcsc-tools/Manifest1
-rw-r--r--sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/sys-apps/pcsc-tools/Manifest b/sys-apps/pcsc-tools/Manifest
index 9476ad0d10af..14db2011fd2b 100644
--- a/sys-apps/pcsc-tools/Manifest
+++ b/sys-apps/pcsc-tools/Manifest
@@ -1,2 +1,3 @@
DIST pcsc-tools-1.5.5.tar.bz2 287752 BLAKE2B dd0563f75c2b1cd05f21916287ff98c8b5f0c444b71ac7cda4da3a9dbf2db58f92555d54029a73feffd651b42ccae820670df1a90c8541eab188bf66b51ad114 SHA512 b34eaea663274e03790e409909ddb9819b20882795af2618068f59532e2f79973b22b4d0c468a0bb4338c74d1ceca310e8c60005fb1d15ab4f34053125ece3bf
DIST pcsc-tools-1.5.6.tar.bz2 289691 BLAKE2B 35dd50a3a8babff89f9e5d769ef70a573e58b2780d680c82dfa07177a3daaf527b5ccca665c901f9667ca4a81719916bd5aebb2e9b1b4d0301001498fe587832 SHA512 94076ed5af698afcec05da9645d7108c02c110fd0ee5efecbd8e0c7eb5ed9a55ee857d23b79ab2ccb93847f8a36f996fa9d521d999395f63274d4bf1d9cf3d26
+DIST pcsc-tools-1.5.7.tar.bz2 292637 BLAKE2B f0bfa9f680a2f2b348d2baef4b4b4567008163f47d7d7e6cec694cdc424626c5c6f18c475f0e8d4c5cd49111315b3c8a934fecf30afe90bbebc0a15f8d6f4a1d SHA512 58d70f41c5815297def7d8b64807e960db85719996771ecb43a4320d3f3fc82e2deb133d9ca97b3a4e8e76267294b3339d8883ba4770bdd0071566e1ce457501
diff --git a/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild b/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild
new file mode 100644
index 000000000000..d3b2711916dc
--- /dev/null
+++ b/sys-apps/pcsc-tools/pcsc-tools-1.5.7.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop toolchain-funcs xdg-utils
+
+DESCRIPTION="PC/SC Architecture smartcard tools"
+HOMEPAGE="http://ludovic.rousseau.free.fr/softwares/pcsc-tools/ https://github.com/LudovicRousseau/pcsc-tools"
+SRC_URI="http://ludovic.rousseau.free.fr/softwares/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="gtk network-cron"
+
+DEPEND=">=sys-apps/pcsc-lite-1.4.14"
+RDEPEND="${DEPEND}
+ dev-perl/pcsc-perl
+ gtk? ( dev-perl/Gtk2 )"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=(
+ README Changelog
+)
+
+src_compile() {
+ # explicitly only build the pcsc_scan application, or the man
+ # pages will be gzipped first, and then unpacked.
+ emake pcsc_scan CC=$(tc-getCC)
+}
+
+src_install() {
+ einstalldocs
+
+ # install manually, makes it much easier since the Makefile
+ # requires fiddling with
+ dobin ATR_analysis scriptor pcsc_scan
+ doman pcsc_scan.1 scriptor.1p ATR_analysis.1p
+
+ if use gtk; then
+ domenu gscriptor.desktop
+ dobin gscriptor
+ doman gscriptor.1p
+ fi
+
+ if use network-cron ; then
+ exeinto /etc/cron.monthly
+ newexe "${FILESDIR}"/smartcard.cron update-smartcard_list
+ fi
+
+ insinto /usr/share/pcsc
+ doins smartcard_list.txt
+}
+
+pkg_postinst() {
+ use gtk && xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}