summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-06-15 18:59:36 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2024-06-15 19:01:34 -0700
commitcebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40 (patch)
tree577fddaa0ec36cabdf762beed423c0f06784e197 /sys-block
parentdev-texlive/texlive-langkorean: Stabilize 2023_p54074-r1 ppc64, #934299 (diff)
downloadgentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.tar.gz
gentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.tar.bz2
gentoo-cebb8ab7b1fc4b4fe9cfa107f3fd1d3b2b535d40.zip
sys-block/sas2ircu: EAPI=8 fixes
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://bugs.gentoo.org/335749
Diffstat (limited to 'sys-block')
-rw-r--r--sys-block/sas2ircu/Manifest2
-rw-r--r--sys-block/sas2ircu/sas2ircu-20-r1.ebuild (renamed from sys-block/sas2ircu/sas2ircu-20.ebuild)59
2 files changed, 33 insertions, 28 deletions
diff --git a/sys-block/sas2ircu/Manifest b/sys-block/sas2ircu/Manifest
index 1726a069fa4a..b91c1c8bdbfa 100644
--- a/sys-block/sas2ircu/Manifest
+++ b/sys-block/sas2ircu/Manifest
@@ -1,2 +1,2 @@
DIST SAS2IRCU_P20.zip 2777958 BLAKE2B ba8c3ef1cf353af90f32a53722b3a7039768c0f48e1d5b48766acdf1c1c05a039692e1edc2586140da5af0f1f2378f4bfaca219895317dc7974004f3aed25343 SHA512 a0a4fa7d07959aa6a81d3540e71e3cc248c23267875ca098da6a80850e008cbdf57b2d6456b5fe17ef890fd39ac550788c9769d169a0673578632f1a8c8a8311
-DIST SAS2_IR_User_Guide.pdf 999388 BLAKE2B 4f1a198ccaa04cf250430106e3254cfb37fd16a1e89861030ed92f52de1d8cff17337709bb641093d78acb44995c03fceff739a0c416f7e3b1692c3b8c6a85dc SHA512 7370b54021978eb543270c992569637092571eaad73896b4bfdf7c7bc45bfd0cb0c6f8f34468255372103f562eb1e3ce2ad30cc6f0d37e7f9bc23f61ee166355
+DIST SAS2IRCU_User_Guide.pdf 794046 BLAKE2B e976f57ada3c51b58bfee24cd2f5d059f59b48bf388d93b146238d54aa09b06f6d450e3ccf149903871dfcdb32807a35d6f379738e149b410b7c1279f811153f SHA512 515869794be428ffbefcbfadac992912fb0eebab0cda640b315b4a231b5f25f1205978605f108b9009380015f3058c47e0ce4352c693ef23ab31980ea8b821a0
diff --git a/sys-block/sas2ircu/sas2ircu-20.ebuild b/sys-block/sas2ircu/sas2ircu-20-r1.ebuild
index 6113f2cb5019..6fc257827999 100644
--- a/sys-block/sas2ircu/sas2ircu-20.ebuild
+++ b/sys-block/sas2ircu/sas2ircu-20-r1.ebuild
@@ -1,48 +1,48 @@
# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit mount-boot
+MY_PN=SAS2IRCU
+MY_P="${MY_PN}_P${PV}"
+
+DISTFILE_BIN=${MY_P}.zip
+DISTFILE_DOC="SAS2IRCU_User_Guide.pdf"
+DOC_PV=12
+SRC_URI_BIN="https://docs.broadcom.com/docs/${DISTFILE_BIN}"
+# This is "SAS-2 Integrated RAID Configuration Utility (SAS2IRCU) User Guide"
+# and replaces the older SAS2_IR_User_Guide.pdf.
+# It contains additional material compared to the older PDF.
+SRC_URI_DOC="https://docs.broadcom.com/doc/12353380"
+
+inherit mount-boot secureboot
DESCRIPTION="LSI MPT-SAS2 controller management tool"
HOMEPAGE="https://www.broadcom.com/products/storage/host-bus-adapters/sas-9207-8e#tab-archive-drivers4-abc"
+SRC_URI="
+${SRC_URI_BIN}
+doc? ( ${SRC_URI_DOC} -> ${DISTFILE_DOC} )
+"
+S="${WORKDIR}/${MY_P}"
LICENSE="LSI"
SLOT="0"
KEYWORDS="-* ~amd64 ~ppc64 ~x86 ~x64-solaris"
-IUSE="uefi doc"
+IUSE="doc uefi"
RESTRICT="strip fetch mirror"
-DEPEND="app-arch/unzip"
-RDEPEND=""
+BDEPEND="app-arch/unzip"
QA_PREBUILT="opt/lsi/sas2ircu boot/efi/sas2ircu.efi"
-MY_PN=SAS2IRCU
-MY_P="${MY_PN}_P${PV}"
-
-DISTFILE_BIN=${MY_P}.zip
-DISTFILE_DOC=SAS2_IR_User_Guide.pdf
-DOC_PV=12
-
-SRC_URI="
-https://docs.broadcom.com/docs/${DISTFILE_BIN}
-https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/sas_sata_6g_p20_point6/$DISTFILE_BIN
-doc? ( https://docs.broadcom.com/docs-and-downloads/host-bus-adapters/host-bus-adapters-common-files/SAS2_IR_User_Guide.pdf )
-"
-
LICENSE_URL="http://www.lsi.com/cm/License.do?url=&prodName=&subType=Miscellaneous&locale=EN"
-S="${WORKDIR}/${MY_P}"
-
pkg_nofetch() {
elog "LSI has a mandatory click-through license on thier binaries."
- elog "Please visit $HOMEPAGE and download ${DISTFILE_BIN} from the Management Software and Tools section."
- elog "If the file has been moved again, the license form might be available at https://docs.broadcom.com/docs/${DISTFILE_BIN}"
+ elog "Please visit ${SRC_URI_BIN} to agree to the license and download the binary."
elog "After downloading, move ${DISTFILE_BIN} into your DISTDIR directory"
if use doc; then
- elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' (${DISTFILE_DOC}) "
- elog "and also place it into your DISTDIR directory"
+ elog "Please also download 'SAS-2 Integrated RAID Configuration Utility User Guide' at ${SRC_URI_DOC}"
+ elog "and also place it into your DISTDIR directory, named ${DISTFILE_DOC}"
fi
}
@@ -90,10 +90,15 @@ src_install() {
use ppc64 && doexe sas2ircu_linux_x86_rel/sas2ircu
use x64-solaris && doexe sas2ircu_solaris_x86_rel/sas2ircu
if use uefi; then
- exeinto /boot/efi/
- doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
+ if use amd64; then
+ exeinto /boot/efi/
+ doexe sas2ircu_efi_ebc_rel/sas2ircu.efi
+ secureboot_auto_sign --in-place
+ fi
fi
dodoc Readme_Release_Notes_SAS2IRCU_Phase_${PV}.00.00.00.txt
dodoc SAS2IRCU_Phase${PV}.0-${PV}.00.00.00.pdf
- use doc && dodoc "${DISTDIR}"/$DISTFILE_DOC
+ use doc && dodoc "${DISTDIR}"/${DISTFILE_DOC}
+ dodir /opt/bin
+ dosym ../lsi/sas2ircu /opt/bin/sas2ircu
}