summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-03-19 10:56:46 -0700
committerZac Medico <zmedico@gentoo.org>2022-03-19 11:01:25 -0700
commit3bcce32317e64e002e9f2816e76576c9287e081b (patch)
tree8b389dc0787295c478a50a4c6039db04862e4be7 /sys-cluster
parentgnome-base/gnome-control-center: Drop USE=flickr description (diff)
downloadgentoo-3bcce32317e64e002e9f2816e76576c9287e081b.tar.gz
gentoo-3bcce32317e64e002e9f2816e76576c9287e081b.tar.bz2
gentoo-3bcce32317e64e002e9f2816e76576c9287e081b.zip
sys-cluster/k3s: patch for go-1.18
Closes: https://bugs.gentoo.org/835601 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-cluster')
-rw-r--r--sys-cluster/k3s/k3s-1.23.4_p1.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/sys-cluster/k3s/k3s-1.23.4_p1.ebuild b/sys-cluster/k3s/k3s-1.23.4_p1.ebuild
index 9416158cb176..6475669db7f5 100644
--- a/sys-cluster/k3s/k3s-1.23.4_p1.ebuild
+++ b/sys-cluster/k3s/k3s-1.23.4_p1.ebuild
@@ -54,6 +54,10 @@ src_prepare() {
local CONTAINERD_DIR=build/src/github.com/containerd/containerd
mkdir -p "${CONTAINERD_DIR}" || die
tar -x --strip-components=1 -f "${DISTDIR}/k3s-containerd-${K3S_CONTAINERD_VERSION}.tar.gz" -C "${CONTAINERD_DIR}" || die
+ if has_version -b ">=dev-lang/go-1.18"; then
+ # https://bugs.gentoo.org/835601
+ sed -i -e "/github.com\/containerd\/containerd => .\/.empty-mod/d" "${CONTAINERD_DIR}"/{go.mod,vendor/modules.txt} || die
+ fi
local RUNC_DIR=build/src/github.com/opencontainers/runc
mkdir -p "${RUNC_DIR}" || die