summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2022-11-10 09:43:01 +0000
committerMatthew Smith <matthew@gentoo.org>2022-11-10 09:44:05 +0000
commitcb42d493187bcd84a0b37110aae09c0a519a109e (patch)
tree8eea539889aa710cbd37510edda99312e8647d43 /sys-devel/mold
parentdev-java/lzma: use 'unpacker' eclass (diff)
downloadgentoo-cb42d493187bcd84a0b37110aae09c0a519a109e.tar.gz
gentoo-cb42d493187bcd84a0b37110aae09c0a519a109e.tar.bz2
gentoo-cb42d493187bcd84a0b37110aae09c0a519a109e.zip
sys-devel/mold: remove system-tbb USE flag
Latest upstream version now contains the required fixes, so it can be reliably used instead of the vendored copy. Bug: https://bugs.gentoo.org/866407 Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'sys-devel/mold')
-rw-r--r--sys-devel/mold/mold-1.6.0-r1.ebuild (renamed from sys-devel/mold/mold-1.6.0.ebuild)8
1 files changed, 3 insertions, 5 deletions
diff --git a/sys-devel/mold/mold-1.6.0.ebuild b/sys-devel/mold/mold-1.6.0-r1.ebuild
index f440beb10d38..45c7fd085eb8 100644
--- a/sys-devel/mold/mold-1.6.0.ebuild
+++ b/sys-devel/mold/mold-1.6.0-r1.ebuild
@@ -17,15 +17,13 @@ fi
# mold (AGPL-3)
# - xxhash (BSD-2)
-# - tbb (Apache-2.0)
-LICENSE="AGPL-3 Apache-2.0 BSD-2"
+LICENSE="AGPL-3 BSD-2"
SLOT="0"
-IUSE="system-tbb"
RDEPEND="
app-arch/zstd:=
+ >=dev-cpp/tbb-2021.7.0:=
sys-libs/zlib
- system-tbb? ( >=dev-cpp/tbb-2021.4.0:= )
!kernel_Darwin? (
>=dev-libs/mimalloc-2:=
dev-libs/openssl:=
@@ -75,7 +73,7 @@ src_configure() {
-DMOLD_ENABLE_QEMU_TESTS=OFF
-DMOLD_LTO=OFF # Should be up to the user to decide this with CXXFLAGS.
-DMOLD_USE_SYSTEM_MIMALLOC=ON
- -DMOLD_USE_SYSTEM_TBB=$(usex system-tbb)
+ -DMOLD_USE_SYSTEM_TBB=ON
)
cmake_src_configure
}