summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zmedico@gentoo.org>2022-06-18 15:14:33 -0700
committerZac Medico <zmedico@gentoo.org>2022-06-18 15:14:33 -0700
commitbbd4a2a9700b11ed9cb065018553f6c476ea8063 (patch)
treefaacf20a943cc959079da990f30b4a13d8c16391 /sys-fabric
parentdev-db/rqlite: add 7.5.1 (diff)
downloadgentoo-bbd4a2a9700b11ed9cb065018553f6c476ea8063.tar.gz
gentoo-bbd4a2a9700b11ed9cb065018553f6c476ea8063.tar.bz2
gentoo-bbd4a2a9700b11ed9cb065018553f6c476ea8063.zip
sys-fabric/mstflint: add 4.20.0_p1
Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'sys-fabric')
-rw-r--r--sys-fabric/mstflint/Manifest1
-rw-r--r--sys-fabric/mstflint/mstflint-4.20.0_p1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-fabric/mstflint/Manifest b/sys-fabric/mstflint/Manifest
index e3914046bff0..f31f8e3f09a6 100644
--- a/sys-fabric/mstflint/Manifest
+++ b/sys-fabric/mstflint/Manifest
@@ -1 +1,2 @@
DIST mstflint-4.18.0_p1.tar.gz 4877851 BLAKE2B 7fb995561155ccc73b0c36d2994c0398483a92788c5ce045f0263a3e5b0ff7230ca8bb0f5b821e957d5879e0629f11716b179e3bc581849335cc95715631c1d6 SHA512 aed2302dc88b9b95892eb6dd929a922ac6257ddae808db656c7fd01c393f9f0a0d3aa4e13da6c07fe0118cd48a43795f39cc16e619408b05e6bed7d085dbf0d4
+DIST mstflint-4.20.0_p1.tar.gz 5176386 BLAKE2B 065fbf1884de70b57b602bb2a46e34c903b7419050622f2e6d55589f066555a43e781e35cfa4751f4d3af4394f3bbcff3c61e5618acb6696d0c22790ccaf50b8 SHA512 7298c425831f6e8f80145fb0f79af9d63ed013eeac6a99a5d9fe804a6e5c044ecffaf0ce62cd3edd07d185732bdb6ae3a99ecbb31b94047831d710b0b7fe1738
diff --git a/sys-fabric/mstflint/mstflint-4.20.0_p1.ebuild b/sys-fabric/mstflint/mstflint-4.20.0_p1.ebuild
new file mode 100644
index 000000000000..d323798bc98f
--- /dev/null
+++ b/sys-fabric/mstflint/mstflint-4.20.0_p1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="Mstflint - an open source version of MFT (Mellanox Firmware Tools)"
+HOMEPAGE="https://github.com/Mellanox/mstflint"
+LICENSE="|| ( GPL-2 BSD-2 )"
+KEYWORDS="~amd64 ~x86"
+EGIT_COMMIT="d23c7b44193a6697a49211d2232dfe094a0e6530"
+MY_PV=${PV/_p/-}
+MY_P=""
+SRC_URI="https://github.com/Mellanox/mstflint/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+IUSE="adb-generic-tools inband ssl"
+SLOT="0"
+RDEPEND="dev-db/sqlite:3=
+ sys-libs/zlib:=
+ inband? ( sys-cluster/rdma-core )
+ adb-generic-tools? (
+ dev-libs/boost:=
+ dev-libs/expat:=
+ )
+ ssl? ( dev-libs/openssl:= )"
+DEPEND="${RDEPEND}"
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_prepare() {
+ default
+ echo '#define TOOLS_GIT_SHA "'${EGIT_COMMIT}'"' > ./common/gitversion.h || die
+}
+
+src_configure() {
+ eautoreconf
+ econf $(use_enable inband) $(use_enable ssl openssl) $(use adb-generic-tools && printf -- '--enable-adb-generic-tools')
+}
+
+src_compile() {
+ if use adb-generic-tools; then
+ pushd ext_libs/json >/dev/null || die
+ emake
+ popd >/dev/null || die
+ fi
+ default
+}