summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2022-01-24 07:37:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2022-01-24 07:39:18 +0100
commitf38971c404a0affd0cfec6587af9c621281eedc6 (patch)
tree98c60aa02449bb032d57204216afa67ef33dbfb2 /sys-fs/ddrescue/ddrescue-1.26.ebuild
parentx11-libs/motif: Add bug tracker to metadata (diff)
downloadgentoo-f38971c404a0affd0cfec6587af9c621281eedc6.tar.gz
gentoo-f38971c404a0affd0cfec6587af9c621281eedc6.tar.bz2
gentoo-f38971c404a0affd0cfec6587af9c621281eedc6.zip
sys-fs/ddrescue: Bump to version 1.26
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/ddrescue/ddrescue-1.26.ebuild')
-rw-r--r--sys-fs/ddrescue/ddrescue-1.26.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-fs/ddrescue/ddrescue-1.26.ebuild b/sys-fs/ddrescue/ddrescue-1.26.ebuild
new file mode 100644
index 000000000000..6bfb7ba4f767
--- /dev/null
+++ b/sys-fs/ddrescue/ddrescue-1.26.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs flag-o-matic unpacker
+
+DESCRIPTION="Copy data from one file or block device to another with read-error recovery"
+HOMEPAGE="https://www.gnu.org/software/ddrescue/ddrescue.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux"
+IUSE="static"
+
+DEPEND="$(unpacker_src_uri_depends)"
+RDEPEND=""
+
+src_configure() {
+ use static && append-ldflags -static
+
+ # not a normal configure script
+ econf \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}
+
+src_test() {
+ ./testsuite/check.sh "${S}"/testsuite || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install-man
+ einstalldocs
+}