summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2019-10-12 21:38:40 -0400
committerJoshua Kinard <kumba@gentoo.org>2019-10-12 21:38:40 -0400
commitc4ee012c2522cb7d0bb79024bd7d14f49de5e460 (patch)
treec12c4c4c49e4ee82a3531bf3071cacb93fc439cc /sys-kernel/mips-sources
parentmedia-libs/libvpx: drop alpha keywords, bug 693510 (diff)
downloadgentoo-c4ee012c2522cb7d0bb79024bd7d14f49de5e460.tar.gz
gentoo-c4ee012c2522cb7d0bb79024bd7d14f49de5e460.tar.bz2
gentoo-c4ee012c2522cb7d0bb79024bd7d14f49de5e460.zip
sys-kernel/mips-sources: Fix issue in src_unpack when no USE flags are set
Also fix a minor grammar issue in show_ip27_info() Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-2.3.76, Repoman-2.3.17
Diffstat (limited to 'sys-kernel/mips-sources')
-rw-r--r--sys-kernel/mips-sources/mips-sources-4.19.78.ebuild16
1 files changed, 7 insertions, 9 deletions
diff --git a/sys-kernel/mips-sources/mips-sources-4.19.78.ebuild b/sys-kernel/mips-sources/mips-sources-4.19.78.ebuild
index c2f35b632ffa..488455018653 100644
--- a/sys-kernel/mips-sources/mips-sources-4.19.78.ebuild
+++ b/sys-kernel/mips-sources/mips-sources-4.19.78.ebuild
@@ -188,7 +188,7 @@ show_ip22_info() {
show_ip27_info() {
echo -e ""
- ewarn "IP27 on the Origin 2k/Onyx2 systems may be prone to sudden hard lockups."
+ ewarn "IP27 Origin 2k/Onyx2 systems may be prone to sudden hard lockups."
ewarn "The exact trigger is unknown at this time."
echo -e ""
}
@@ -318,18 +318,16 @@ src_unpack() {
for x in {ip27,ip28,ip30}; do
use ${x} && v="${v}.${x}" && break
done
- mv "${WORKDIR}/linux-${fkv/_/-}" "${WORKDIR}/linux-${v}" || die
- S="${WORKDIR}/linux-${v}"
+ local old="${WORKDIR}/linux-${fkv/_/-}"
+ local new="${WORKDIR}/linux-${v}"
+ if [ "${old}" != "${new}" ]; then
+ mv "${old}" "${new}" || die
+ fi
+ S="${new}"
# Set the EXTRAVERSION to linux-VERSION-mipsgit-GITDATE
EXTRAVERSION="${EXTRAVERSION}-gentoo-mips"
unpack_set_extraversion
-# local old="${WORKDIR}/linux-${fkv/_/-}"
-# local new="${WORKDIR}/linux-${v}"
-# if [ "${old}" != "${new}" ]; then
-# mv "${old}" "${new}" || die
-# fi
-# S="${new}"
}
src_prepare() {