summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /sys-power/nut
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-power/nut')
-rw-r--r--sys-power/nut/nut-2.7.4-r1.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/sys-power/nut/nut-2.7.4-r1.ebuild b/sys-power/nut/nut-2.7.4-r1.ebuild
index 33146bc92d79..48deb79389f8 100644
--- a/sys-power/nut/nut-2.7.4-r1.ebuild
+++ b/sys-power/nut/nut-2.7.4-r1.ebuild
@@ -155,7 +155,7 @@ src_configure() {
}
src_install() {
- emake DESTDIR="${D}" install || die
+ emake DESTDIR="${D}" install
find "${D}" -name '*.la' -exec rm -f {} +
@@ -174,19 +174,19 @@ src_install() {
mv "${i}" "${i/.sample/}"
done
- dodoc AUTHORS ChangeLog docs/*.txt MAINTAINERS NEWS README TODO UPGRADING || die
+ dodoc AUTHORS ChangeLog docs/*.txt MAINTAINERS NEWS README TODO UPGRADING
newdoc lib/README README.lib || die
newdoc "${FILESDIR}"/lighttpd_nut.conf-2.2.0 lighttpd_nut.conf || die
docinto cables
- dodoc docs/cables/* || die
+ dodoc docs/cables/*
- newinitd "${FILESDIR}"/nut-2.6.5-init.d-upsd upsd || die
- newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsdrv upsdrv || die
- newinitd "${FILESDIR}"/nut-2.6.5-init.d-upsmon upsmon || die
- newinitd "${FILESDIR}"/nut-2.6.5-init.d-upslog upslog || die
- newinitd "${FILESDIR}"/nut.powerfail.initd nut.powerfail || die
+ newinitd "${FILESDIR}"/nut-2.6.5-init.d-upsd upsd
+ newinitd "${FILESDIR}"/nut-2.2.2-init.d-upsdrv upsdrv
+ newinitd "${FILESDIR}"/nut-2.6.5-init.d-upsmon upsmon
+ newinitd "${FILESDIR}"/nut-2.6.5-init.d-upslog upslog
+ newinitd "${FILESDIR}"/nut.powerfail.initd nut.powerfail
keepdir /var/lib/nut