summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authortastytea <gentoo@tastytea.de>2023-09-08 20:41:51 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-09-11 12:37:23 +0300
commitb71e686b8a07ba5e66a951933f3f603f7b4b3197 (patch)
tree31df53344536b3ef921638051b6761850944a3c7 /www-apps
parentnet-fs/s3fs: Stabilize 1.93 amd64, #913964 (diff)
downloadgentoo-b71e686b8a07ba5e66a951933f3f603f7b4b3197.tar.gz
gentoo-b71e686b8a07ba5e66a951933f3f603f7b4b3197.tar.bz2
gentoo-b71e686b8a07ba5e66a951933f3f603f7b4b3197.zip
www-apps/hugo: add 0.118.2
Signed-off-by: tastytea <gentoo@tastytea.de> Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/hugo/Manifest2
-rw-r--r--www-apps/hugo/files/hugo-0.118.2-skip-some-tests.patch65
-rw-r--r--www-apps/hugo/hugo-0.118.2.ebuild98
3 files changed, 165 insertions, 0 deletions
diff --git a/www-apps/hugo/Manifest b/www-apps/hugo/Manifest
index d3e4594b58cd..be5b2f3abdce 100644
--- a/www-apps/hugo/Manifest
+++ b/www-apps/hugo/Manifest
@@ -2,3 +2,5 @@ DIST hugo-0.115.2-vendor.tar.xz 6196068 BLAKE2B 0d98ed1f3553c5eb28ceb66751c36d4b
DIST hugo-0.115.2.tar.gz 28547893 BLAKE2B 18496be5d24be6b0b34ff88806b6621cb361f61641efd67ed11fd413379107aad029b241a7b8730ad016c1eb1469b29feee7af33fbf0b94bb0f2fbe2a209c1bb SHA512 4c35d5d6699de1e675fa0c1dfca0f2436ac3ab7a0c164e7662400fb7b81b16ed23a6961e297f262273c18ef2eaa551b813c7d99a8634d0687e78343b23f275f6
DIST hugo-0.115.4-vendor.tar.xz 6193628 BLAKE2B 427dc6c66a726ff944b0c782b443a6ae3d3ec1b916127db33ebb6789dc1a8271daf00a3bf47f4fbd4f18fc01648b632c5ad9978237d4a11aac0c30406626c107 SHA512 57d3a421eec9909995453aad032f7775722e6ea72c344a31337c62c0aa7b4b669cf5ba5229e3f6819845eed03712e9972328c13c14f93bee0b97a5392b49779b
DIST hugo-0.115.4.tar.gz 28554509 BLAKE2B b0a8776580b60af5b4e8d023ed2c046fec1d508eaef568fa06f8591653e0f3a2e1bb65352328de421353c02a5856a6cc713d15b6189184150fabc6a5d3a152b9 SHA512 b5a00aa6601a6df2d1cc9244899b26abdc92e0b57d7431409b483e1bbd892a8026b181f2b9dbe273385b5ca95c3564ca6128afa54d33cbda584946eba20d2eb5
+DIST hugo-0.118.2-vendor.tar.xz 6633368 BLAKE2B a88e3422828a98ae220805a5853402b62c2b602de03909187a3694b1546a3fb27f9cb39651342039b5031840fd57e6f00152d5ff023628c6d491ee33245d3b24 SHA512 2e617cccf23931ba20dfac703445c63d0bebdf6178c943315dd7d4983b2a4626c1631751e3bbd925a247599af918638161d13b3e2af474e80ec204aa9ad0e2f6
+DIST hugo-0.118.2.tar.gz 19385307 BLAKE2B c5a4e358b37f41cdbadb12df4657570da249fb8ba70f3c18406431cf8a48287d14598e6c36453a53afe156eb2fdd6c177586136f32e1166d23c856a2fab98bc1 SHA512 decda9097ae3e9942524457527ecd2a1d0c8555b5909c676f2bcc16ca5052453a64366f3dbe5eeb2ef0930b65edd52d9963c967cf28f0b149fb410aa5811ac78
diff --git a/www-apps/hugo/files/hugo-0.118.2-skip-some-tests.patch b/www-apps/hugo/files/hugo-0.118.2-skip-some-tests.patch
new file mode 100644
index 000000000000..66b5bac5ef87
--- /dev/null
+++ b/www-apps/hugo/files/hugo-0.118.2-skip-some-tests.patch
@@ -0,0 +1,65 @@
+From 416992cf1404a78560a5e718a584c5fa1f2f9143 Mon Sep 17 00:00:00 2001
+From: tastytea <tastytea@tastytea.de>
+Date: Fri, 8 Sep 2023 20:01:03 +0200
+Subject: [PATCH] skip some tests
+
+reasons:
+ - needs to be in a git repo
+ - needs special test dependencies
+ - requires network access
+---
+ modules/client_test.go | 4 ++++
+ resources/resource_factories/create/integration_test.go | 1 +
+ 2 files changed, 5 insertions(+)
+
+diff --git a/modules/client_test.go b/modules/client_test.go
+index 75e3c2b08..235d6ed32 100644
+--- a/modules/client_test.go
++++ b/modules/client_test.go
+@@ -68,6 +68,7 @@ github.com/gohugoio/hugoTestModules1_darwin/modh2_2@v1.4.0 github.com/gohugoio/h
+ }
+
+ c.Run("All", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ client, clean := newClient(c, func(cfg *ClientConfig) {
+ cfg.ModuleConfig = DefaultModuleConfig
+ }, defaultImport)
+@@ -107,6 +108,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("IgnoreVendor", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ client, clean := newClient(
+ c, func(cfg *ClientConfig) {
+ cfg.ModuleConfig = DefaultModuleConfig
+@@ -125,6 +127,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("NoVendor", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ mcfg := DefaultModuleConfig
+ mcfg.NoVendor = "**"
+ client, clean := newClient(
+@@ -144,6 +147,7 @@ project github.com/gohugoio/hugoTestModules1_darwin/modh2_2_2@v1.3.0+vendor
+ })
+
+ c.Run("VendorClosest", func(c *qt.C) {
++ c.Skip("Test dependencies not available")
+ mcfg := DefaultModuleConfig
+ mcfg.VendorClosest = true
+
+diff --git a/resources/resource_factories/create/integration_test.go b/resources/resource_factories/create/integration_test.go
+index 140c5d091..721a9fc5b 100644
+--- a/resources/resource_factories/create/integration_test.go
++++ b/resources/resource_factories/create/integration_test.go
+@@ -25,6 +25,7 @@ import (
+ )
+
+ func TestGetRemoteHead(t *testing.T) {
++ t.Skip("Requires network access")
+
+ files := `
+ -- config.toml --
+--
+2.41.0
+
diff --git a/www-apps/hugo/hugo-0.118.2.ebuild b/www-apps/hugo/hugo-0.118.2.ebuild
new file mode 100644
index 000000000000..12937987bc02
--- /dev/null
+++ b/www-apps/hugo/hugo-0.118.2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 2018-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module bash-completion-r1
+
+DESCRIPTION="Fast static HTML and CSS website generator"
+HOMEPAGE="https://gohugo.io https://github.com/gohugoio/hugo"
+SRC_URI="
+ https://github.com/gohugoio/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://tastytea.de/files/gentoo/${P}-vendor.tar.xz
+"
+
+# NOTE: To create the vendor tarball, run:
+# `go mod vendor && cd .. && tar -caf ${P}-vendor.tar.xz ${P}/vendor`
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~loong ~riscv ~x86"
+IUSE="doc +sass test"
+
+BDEPEND="
+ >=dev-lang/go-1.18
+ test? (
+ dev-python/docutils
+ dev-ruby/asciidoctor
+ virtual/pandoc
+ )
+"
+RDEPEND="
+ >=media-libs/libwebp-1.2.3-r1:=
+ sass? ( dev-libs/libsass:= )
+"
+DEPEND="${RDEPEND}"
+
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.96.0-unbundle-libwebp-and-libsass.patch
+ "${FILESDIR}"/${PN}-0.118.2-skip-some-tests.patch
+)
+
+src_configure() {
+ export CGO_ENABLED=1
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export MY_BUILD_FLAGS="$(usev sass "-tags extended")"
+
+ default
+}
+
+src_prepare() {
+ # wants to run command that require network access
+ rm testscripts/commands/mod{,_vendor,__disable}.txt || die
+
+ default
+}
+
+src_compile() {
+ mkdir -pv bin || die
+ ego build -ldflags "-X github.com/gohugoio/hugo/common/hugo.vendorInfo=gentoo:${PVR}" \
+ ${MY_BUILD_FLAGS} -o "${S}/bin/hugo"
+
+ bin/hugo gen man --dir man || die
+
+ mkdir -pv completions || die
+ bin/hugo completion bash > completions/hugo || die
+ bin/hugo completion fish > completions/hugo.fish || die
+ bin/hugo completion zsh > completions/_hugo || die
+
+ if use doc ; then
+ bin/hugo gen doc --dir doc || die
+ fi
+}
+
+src_test() {
+ ego test "./..." ${MY_BUILD_FLAGS}
+}
+
+src_install() {
+ dobin bin/*
+ doman man/*
+
+ dobashcomp completions/${PN}
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins completions/${PN}.fish
+
+ insinto /usr/share/zsh/site-functions
+ doins completions/_${PN}
+
+ if use doc ; then
+ dodoc -r doc/*
+ fi
+}