summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-04-20 13:20:31 -0400
committerMike Gilbert <floppym@gentoo.org>2017-04-20 13:21:02 -0400
commit569031d808ea3e936f71a9fcc4c6c33aa05aa493 (patch)
tree23091ce22986da715b0badb99aed079c5ff029d8 /www-client/chromium
parentnet-misc/libres3: fix dep for split lwt (diff)
downloadgentoo-569031d808ea3e936f71a9fcc4c6c33aa05aa493.tar.gz
gentoo-569031d808ea3e936f71a9fcc4c6c33aa05aa493.tar.bz2
gentoo-569031d808ea3e936f71a9fcc4c6c33aa05aa493.zip
www-client/chromium: pass --no-clean to GN bootstrap script
This may aid in debugging if the built gn fails to run. Bug: https://bugs.gentoo.org/615902 Package-Manager: Portage-2.3.5_p19, Repoman-2.3.2_p49
Diffstat (limited to 'www-client/chromium')
-rw-r--r--www-client/chromium/chromium-58.0.3029.81.ebuild2
-rw-r--r--www-client/chromium/chromium-59.0.3067.0.ebuild2
2 files changed, 2 insertions, 2 deletions
diff --git a/www-client/chromium/chromium-58.0.3029.81.ebuild b/www-client/chromium/chromium-58.0.3029.81.ebuild
index 306b006b0325..90c93ae0e60d 100644
--- a/www-client/chromium/chromium-58.0.3029.81.ebuild
+++ b/www-client/chromium/chromium-58.0.3029.81.ebuild
@@ -509,7 +509,7 @@ src_configure() {
einfo "Configuring Chromium..."
# TODO: bootstrapped gn binary hangs when using tcmalloc with portage's sandbox.
- tools/gn/bootstrap/bootstrap.py -v --gn-gen-args "${myconf_gn} use_allocator=\"none\"" || die
+ tools/gn/bootstrap/bootstrap.py -v --no-clean --gn-gen-args "${myconf_gn} use_allocator=\"none\"" || die
myconf_gn+=" use_allocator=$(usex tcmalloc \"tcmalloc\" \"none\")"
out/Release/gn gen --args="${myconf_gn}" out/Release || die
}
diff --git a/www-client/chromium/chromium-59.0.3067.0.ebuild b/www-client/chromium/chromium-59.0.3067.0.ebuild
index ead35d303d6f..c8063a88539e 100644
--- a/www-client/chromium/chromium-59.0.3067.0.ebuild
+++ b/www-client/chromium/chromium-59.0.3067.0.ebuild
@@ -512,7 +512,7 @@ src_configure() {
touch chrome/test/data/webui/i18n_process_css_test.html || die
einfo "Configuring Chromium..."
- tools/gn/bootstrap/bootstrap.py -v --gn-gen-args "${myconf_gn}" || die
+ tools/gn/bootstrap/bootstrap.py -v --no-clean --gn-gen-args "${myconf_gn}" || die
out/Release/gn gen --args="${myconf_gn}" out/Release || die
}