summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPedro Arizmendi <dwosky@zoho.com>2019-03-21 17:45:48 +0100
committerPatrice Clement <monsieurp@gentoo.org>2019-04-09 09:29:06 +0200
commite53604532f966e9c3399169b87d30b16cd4e7070 (patch)
tree467be1de3734f0002052729ba02b5f18304b759d /www-misc
parentapp-vim/ri-browser: EAPI7 bump. (diff)
downloadgentoo-e53604532f966e9c3399169b87d30b16cd4e7070.tar.gz
gentoo-e53604532f966e9c3399169b87d30b16cd4e7070.tar.bz2
gentoo-e53604532f966e9c3399169b87d30b16cd4e7070.zip
www-misc/monitorix: version bump to 3.11.0.
- Updated monitorix to version 3.11.0 - Fixed systemd script bug referencing the wrong path - Updated init.d script to avoid issues Closes: https://bugs.gentoo.org/681348 Signed-off-by: Pedro Arizmendi <dwosky@zoho.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11446 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'www-misc')
-rw-r--r--www-misc/monitorix/Manifest1
-rwxr-xr-xwww-misc/monitorix/files/monitorix30
-rw-r--r--www-misc/monitorix/files/monitorix.init24
-rw-r--r--www-misc/monitorix/monitorix-3.11.0.ebuild105
4 files changed, 136 insertions, 24 deletions
diff --git a/www-misc/monitorix/Manifest b/www-misc/monitorix/Manifest
index e309e6b68c6d..563c78fc9e0a 100644
--- a/www-misc/monitorix/Manifest
+++ b/www-misc/monitorix/Manifest
@@ -1,3 +1,4 @@
DIST monitorix-3.10.0.tar.gz 309688 BLAKE2B 58345fbe02e24be48baecb1b91b4c24de8bec1960557e4713c4007c7c1649627d79caf823893eba4f9c9bc1330cc739f2c4e248421795235107ddf5164e998f5 SHA512 a313b25c4b8a614d62d67e9649227461a0faf83704baebb01318acb8d42dc336b747dd5f4a9fc5ddbd7ef10598d96577d1265c0022dfb0a94826e1da5cfc33d2
DIST monitorix-3.10.1.tar.gz 313587 BLAKE2B 2dfc63499966346cf7e862a44d904f2599a6eb40544c511c9d64f1fa32684bccbecccbbfaff8d46cdb1c4af8b5904c2622ede8d3d8f955bd9bacc32848c2ef02 SHA512 b1e2a5c6a2992c6280129ec7fcdd72783902f475c3c98f09aab86b56305efacce7222732669639dc59b29da2fdf5cda49999ee159f4a95b12e4ee3a491d55c55
+DIST monitorix-3.11.0.tar.gz 318741 BLAKE2B af190e716acea9dfa56ebf3976e387abc19d0254fbebf6b6b18deff98b989266bff7e7c59e57832ad8b29dff8abb220e19da079c004ec185b63845cf70fb2727 SHA512 81832ef569416cc2e587beff8dbd485a6d361c0b5f11611522bde58c06d3156888e8c7b49cb3205adafbf737cd2d2b22e6041cd8b94e6d8c78cb5a4c3b1587de
DIST monitorix-3.9.0.tar.gz 288443 BLAKE2B 6203f2950e0061d1ff268a2c42c31e7e14b5103e09ec82411f3ee3b957212c8799ba00710b269e0097ed0a3c060eb2d6972dd7b2c1af820bb09de2281113238c SHA512 599f3fa004c2e9657f255ca0ef0ae69ca63623976d17ebf8883a8c19b8a76193916634844f794da508439336edc37e424263aa6ccd8e06bb3584b6cf3cda783b
diff --git a/www-misc/monitorix/files/monitorix b/www-misc/monitorix/files/monitorix
new file mode 100755
index 000000000000..389119e2e552
--- /dev/null
+++ b/www-misc/monitorix/files/monitorix
@@ -0,0 +1,30 @@
+#!/sbin/openrc-run
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Monitorix"
+description="Monitorix is a lightweight system monitoring tool"
+command=/usr/sbin/monitorix
+command_args="-c /etc/monitorix/monitorix.conf -p /var/run/$name.pid"
+pidfile=/var/run/monitorix.pid
+
+checkconfig() {
+ if [[ ! -e /etc/monitorix/monitorix.conf ]]; then
+ eerror "Please check that the configuration file exists."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+ ebegin "Starting $name"
+ start-stop-daemon --start --name $name --pidfile /var/run/$name.pid --exec $command -- $command_args
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping $name"
+ start-stop-daemon --stop --pidfile /var/run/$name.pid
+ eend $?
+}
+
diff --git a/www-misc/monitorix/files/monitorix.init b/www-misc/monitorix/files/monitorix.init
deleted file mode 100644
index a614bd0bd4a1..000000000000
--- a/www-misc/monitorix/files/monitorix.init
+++ /dev/null
@@ -1,24 +0,0 @@
-#!/sbin/openrc-run
-
-depend() {
- need net
-}
-
-start() {
- ebegin "Starting monitorix"
- start-stop-daemon --start --exec /usr/sbin/monitorix --pidfile /var/run/monitorix.pid -- -c /etc/monitorix/monitorix.conf -p /var/run/monitorix.pid
- local i=0
- local timeout=5
- while [ ! -f /var/run/monitorix.pid ] && [ $i -le $timeout ]; do
- sleep 1
- i=$(($i + 1))
- done
- [ $timeout -gt $i ]
- eend $?
-}
-
-stop() {
- ebegin "Stopping monitorix"
- start-stop-daemon --stop --signal QUIT --stop --exec /usr/sbin/monitorix --pidfile /var/run/monitorix.pid
- eend $?
-}
diff --git a/www-misc/monitorix/monitorix-3.11.0.ebuild b/www-misc/monitorix/monitorix-3.11.0.ebuild
new file mode 100644
index 000000000000..efb99c9012a7
--- /dev/null
+++ b/www-misc/monitorix/monitorix-3.11.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit systemd user
+
+DESCRIPTION="A lightweight system monitoring tool"
+HOMEPAGE="https://www.monitorix.org/"
+SRC_URI="https://www.monitorix.org/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-perl/Config-General
+ dev-perl/DBI
+ dev-perl/HTTP-Server-Simple
+ dev-perl/IO-Socket-SSL
+ dev-perl/libwww-perl
+ dev-perl/MIME-Lite
+ dev-perl/XML-Simple
+ net-analyzer/rrdtool[graph,perl]
+ dev-perl/CGI"
+
+pkg_setup() {
+ enewgroup ${PN}
+ enewuser ${PN} -1 -1 /var/lib/${PN} ${PN}
+}
+
+src_prepare() {
+ # Put better Gentoo defaults in the configuration file.
+ sed -e "s|\(base_dir.*\)/usr/share/${PN}|\1/usr/share/${PN}/htdocs|" \
+ -e "s|\(secure_log.*\)/var/log/secure|\1/var/log/auth.log|" \
+ -e "s|nobody|${PN}|g" -i ${PN}.conf || die
+ # Update systemd binary location
+ sed -e "s|/usr/bin|/usr/sbin|g" -i docs/${PN}.service || die
+ eapply_user
+}
+
+# Override compile phase
+src_compile() { :; }
+
+src_install() {
+ dosbin ${PN}
+
+ newinitd ${FILESDIR}/monitorix ${PN}
+
+ insinto /etc/monitorix
+ doins ${PN}.conf
+
+ keepdir /etc/${PN}/conf.d
+
+ insinto /etc/logrotate.d
+ newins docs/${PN}.logrotate ${PN}
+
+ dodoc Changes README{,.nginx} docs/${PN}-{alert.sh,apache.conf,lighttpd.conf}
+ doman man/man5/${PN}.conf.5
+ doman man/man8/${PN}.8
+
+ insinto /var/lib/${PN}/www
+ doins logo_bot.png logo_top.png ${PN}ico.png
+
+ keepdir /var/lib/${PN}/www/imgs
+ fowners monitorix:monitorix /var/lib/${PN}/www/imgs
+
+ exeinto /var/lib/${PN}/www/cgi
+ doexe ${PN}.cgi
+
+ dodir /usr/lib/${PN}
+ exeinto /usr/lib/${PN}
+ doexe lib/*.pm
+
+ keepdir /var/lib/${PN}/usage
+ insinto /var/lib/${PN}/reports
+ doins -r reports
+
+ systemd_dounit docs/${PN}.service
+}
+
+pkg_postinst() {
+ if has_version '<=www-misc/monitorix-3.5.1' ; then
+ ewarn "WARNING: ${PN} has changed its config format twice, in versions"
+ ewarn "3.0.0 and 3.4.0; this format may be incompatible with your existing"
+ ewarn "config file. Please take care if upgrading from an old version."
+ ewarn
+ elog "${PN} includes its own web server as of version 3.0.0."
+ elog "For this reason, the dependency on the webapp framework"
+ elog "has been removed."
+ elog
+ fi
+ elog "Optional dependencies:"
+ elog " app-admin/hddtemp (disk drive temperatures and health)"
+ elog " mail-mta/postfix (email reports/statics)"
+ elog " mail-mta/sendmail (email reports/statics)"
+ elog " sys-apps/lm_sensors (lm_sensors and GPU temperatures)"
+ elog " sys-power/apcupsd (APC UPS statistics)"
+ elog " sys-power/nut (Network UPS Tools statistics)"
+ elog
+ elog "If you wish to use your own web server:"
+ elog " Web data can be found at: ${EROOT%/}/var/lib/${PN}/www/"
+ elog " Also please check the correct user and group ownership"
+ elog " of ${EROOT%/}/var/lib/${PN}/www/imgs/"
+}