summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-03-11 12:53:52 -0400
committerMatt Turner <mattst88@gentoo.org>2024-03-11 13:05:44 -0400
commit71641d76ea07c310ba5e93e3b1a711f8d75c5588 (patch)
tree64f7f703888b446923614182f2dc361a7954652e /x11-libs
parentdev-java/openjfx: no longer depend on deprecated ant-core (diff)
downloadgentoo-71641d76ea07c310ba5e93e3b1a711f8d75c5588.tar.gz
gentoo-71641d76ea07c310ba5e93e3b1a711f8d75c5588.tar.bz2
gentoo-71641d76ea07c310ba5e93e3b1a711f8d75c5588.zip
x11-libs/libXaw: Version bump to 1.0.16
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libXaw/Manifest1
-rw-r--r--x11-libs/libXaw/libXaw-1.0.16.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/x11-libs/libXaw/Manifest b/x11-libs/libXaw/Manifest
index 54ffe0960da5..e8e513a9a176 100644
--- a/x11-libs/libXaw/Manifest
+++ b/x11-libs/libXaw/Manifest
@@ -1 +1,2 @@
DIST libXaw-1.0.15.tar.xz 589832 BLAKE2B a176b59fbbd7555e7ec2f114a31e9ed804c0ee9e2f7f0efc1ed836caa280947bbe1c66dc4b5155f983a91b649a6303730377b5203d17dcd6af8dfdfa51e7784c SHA512 8edbf280b7b24b9040c291545053c1251d6af7e7f56da43a6065a1848245863eb52bdfc28c2f18dbb6597a4064394a44f4df5d8596a1a467549ccc9ce50a7821
+DIST libXaw-1.0.16.tar.xz 602848 BLAKE2B 342ca47da7fce2ddcc01b12bff6b279ad1ce6a743e3d6cf20120a98d67cc8c533d0c19c33250552d8709c8fc401e72147b04522e9ced998b05b7639a15115e23 SHA512 1cabad1a9b06dec7de601b977e844536823ee1a0045244acc42ca6b6107da9b4953736d94898a96cab40845eab77dae21e20e1fa66a3dfc4dedf575dfbca04aa
diff --git a/x11-libs/libXaw/libXaw-1.0.16.ebuild b/x11-libs/libXaw/libXaw-1.0.16.ebuild
new file mode 100644
index 000000000000..22493f2c8cfc
--- /dev/null
+++ b/x11-libs/libXaw/libXaw-1.0.16.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+XORG_DOC=doc
+XORG_MULTILIB=yes
+XORG_TARBALL_SUFFIX="xz"
+inherit xorg-3
+
+DESCRIPTION="X.Org Xaw library"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="deprecated"
+
+RDEPEND="
+ >=x11-libs/libX11-1.6.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXext-1.3.2[${MULTILIB_USEDEP}]
+ >=x11-libs/libXmu-1.1.1-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXpm-3.5.10-r1[${MULTILIB_USEDEP}]
+ >=x11-libs/libXt-1.1.4[${MULTILIB_USEDEP}]"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_configure() {
+ local XORG_CONFIGURE_OPTIONS=(
+ $(use_enable deprecated xaw6)
+ $(use_enable doc specs)
+ $(use_with doc xmlto)
+ --without-fop
+ )
+ xorg-3_src_configure
+}