summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Eisele <kernlpanic@dennis-eisele.de>2022-01-28 13:57:37 +0100
committerFlorian Schmaus <flow@gentoo.org>2022-02-18 08:28:36 +0100
commit84fa56c783a3b2bb4f34927cb207d5ce3386c6b6 (patch)
treef9e7056ad36feadb3ca5a524db25ec29c4ac2d1b /x11-misc/gpaste
parentmedia-video/rav1e: Stabilize 0.5.1 amd64, #833579 (diff)
downloadgentoo-84fa56c783a3b2bb4f34927cb207d5ce3386c6b6.tar.gz
gentoo-84fa56c783a3b2bb4f34927cb207d5ce3386c6b6.tar.bz2
gentoo-84fa56c783a3b2bb4f34927cb207d5ce3386c6b6.zip
x11-misc/gpaste: bump to version 3.42.2
Closes: https://bugs.gentoo.org/680536 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Dennis Eisele <kernlpanic@dennis-eisele.de> Closes: https://github.com/gentoo/gentoo/pull/23998 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'x11-misc/gpaste')
-rw-r--r--x11-misc/gpaste/Manifest1
-rw-r--r--x11-misc/gpaste/gpaste-3.42.2.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-misc/gpaste/Manifest b/x11-misc/gpaste/Manifest
index e80b091a12ed..3b3b17b94c7d 100644
--- a/x11-misc/gpaste/Manifest
+++ b/x11-misc/gpaste/Manifest
@@ -1 +1,2 @@
DIST gpaste-3.36.3.tar.gz 186352 BLAKE2B b00af3f32076bbeb4f06853a7892772901d0c72dd972d08fff0520afae388bed0c9eee81892a2492f4bb972b3a80a924519e1c137edb660fa5f9dfa2fab31856 SHA512 e5fe4a31367e96089aefd1af5ed0a3ad591eee009bbc74b1b33c9c736061831979d79f2d6a5c072cf55fc6f1982ade581fe73d2039c5dbd607081683860c7b9f
+DIST gpaste-3.42.2.tar.gz 289280 BLAKE2B f133304be36e99324891723914a40b6ba9fb70596f8b6898a012abcf93e013f6c9de3bc5eff85bb12103b4d6c4bb23e497cbe9a8d590453185be67e9e1832312 SHA512 34504fed5a1ccb1d91c2fb301800ce1058404a63a2ddf860bd77485bee6a7c8cfc7f36053e0c6661551eda868022773cc1695b941b6aa2ddf834e317c2c83dce
diff --git a/x11-misc/gpaste/gpaste-3.42.2.ebuild b/x11-misc/gpaste/gpaste-3.42.2.ebuild
new file mode 100644
index 000000000000..925398cc2ed3
--- /dev/null
+++ b/x11-misc/gpaste/gpaste-3.42.2.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+VALA_MIN_API_VERSION="0.30"
+VALA_USE_DEPEND="vapigen"
+
+inherit meson vala gnome2-utils
+
+DESCRIPTION="Clipboard management system"
+HOMEPAGE="https://github.com/Keruspe/GPaste"
+SRC_URI="https://github.com/Keruspe/GPaste/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+gnome +introspection systemd vala"
+REQUIRED_USE="
+ gnome? ( introspection )
+ vala? ( introspection )
+"
+
+DEPEND="
+ dev-libs/appstream-glib
+ >=dev-libs/glib-2.7:2
+ sys-apps/dbus
+ >=x11-libs/gdk-pixbuf-2.34:2
+ >=x11-libs/gtk+-3.24:3
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/pango
+ gnome? (
+ >=x11-wm/mutter-41.3
+ )
+ introspection? (
+ dev-libs/gjs
+ >=dev-libs/gobject-introspection-1.48.0
+ >=x11-wm/mutter-41.3[introspection]
+ )
+"
+BDEPEND="
+ virtual/pkgconfig
+ gnome? (
+ gnome-base/gnome-control-center:2
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+ vala? ( $(vala_depend) )
+"
+RDEPEND="${DEPEND}
+ gnome? (
+ gnome-base/gnome-control-center:2
+ gnome-base/gnome-shell
+ )
+ systemd? (
+ sys-apps/systemd
+ )
+"
+
+S="${WORKDIR}/GPaste-${PV}"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ default
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use systemd systemd)
+ -Dbash-completion=true
+ -Dzsh-completion=true
+ -Dx-keybinder=true
+ -Dcontrol-center-keybindings-dir=$(usex gnome '' \
+ '/usr/share/gnome-control-center/keybindings')
+ $(meson_use introspection introspection)
+ $(meson_use vala vapi)
+ $(meson_use gnome gnome-shell)
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+}