summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgin-birthday-reminder
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgin-birthday-reminder')
-rw-r--r--x11-plugins/pidgin-birthday-reminder/Manifest1
-rw-r--r--x11-plugins/pidgin-birthday-reminder/metadata.xml19
-rw-r--r--x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7.ebuild33
3 files changed, 53 insertions, 0 deletions
diff --git a/x11-plugins/pidgin-birthday-reminder/Manifest b/x11-plugins/pidgin-birthday-reminder/Manifest
new file mode 100644
index 000000000000..8f950ba4a680
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/Manifest
@@ -0,0 +1 @@
+DIST pidgin-birthday-reminder-1.7.tar.gz 470361 SHA256 6ed8292fbf742d122542227891145ffdf2367427178387e3399a0575c126dbe4 SHA512 1213c193b141f006caf9cfa7b55b052f54f00426414353e758224a1aa35a70436c452b52ea25fa088c346f4f0da25af40b2f4991452a2d3aabf13d40c8438e47 WHIRLPOOL 93e7fdf2353d0b9345a8739cf3b2c7b5ff71ebddc1eb3f63dd74e1873b80b8be1474cdf3eb7d5be557a6c3cd1dd8f944eaa5fedf9488566345c1a8812526632a
diff --git a/x11-plugins/pidgin-birthday-reminder/metadata.xml b/x11-plugins/pidgin-birthday-reminder/metadata.xml
new file mode 100644
index 000000000000..4726ce995764
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <maintainer>
+ <email>hasufell@gentoo.org</email>
+ <name>Julian Ospald</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ <description>Maintainer. CC him on bugs</description>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://bugs.launchpad.net/pidgin-birthday-reminder</bugs-to>
+ <remote-id type="launchpad">pidgin-birthday-reminder</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7.ebuild b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7.ebuild
new file mode 100644
index 000000000000..575735ae52a8
--- /dev/null
+++ b/x11-plugins/pidgin-birthday-reminder/pidgin-birthday-reminder-1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="Plugin for Pidgin that reminds you of your buddies birthdays"
+HOMEPAGE="http://launchpad.net/pidgin-birthday-reminder"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="static-libs"
+
+RDEPEND="net-im/pidgin[gtk]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ if ! use static-libs ; then
+ find "${D}" -type f -name '*.la' -delete || die "la removal failed"
+ fi
+}