summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/pidgintex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/pidgintex')
-rw-r--r--x11-plugins/pidgintex/Manifest1
-rw-r--r--x11-plugins/pidgintex/metadata.xml12
-rw-r--r--x11-plugins/pidgintex/pidgintex-1.1.1.ebuild49
3 files changed, 62 insertions, 0 deletions
diff --git a/x11-plugins/pidgintex/Manifest b/x11-plugins/pidgintex/Manifest
new file mode 100644
index 000000000000..1866c2592e84
--- /dev/null
+++ b/x11-plugins/pidgintex/Manifest
@@ -0,0 +1 @@
+DIST pidginTeX-1.1.1.tar.gz 23322 SHA256 1b47e89d12d5f5a8de4f3f89ea37da393223d525632c92e71cef8a54399ac1aa
diff --git a/x11-plugins/pidgintex/metadata.xml b/x11-plugins/pidgintex/metadata.xml
new file mode 100644
index 000000000000..820799abbc00
--- /dev/null
+++ b/x11-plugins/pidgintex/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-im</herd>
+ <longdescription>pidginTeX is a fast plugin for the instant messaging client Pidgin and uses
+mimeTeX or mathTeX to render LaTeX expressions in messages and chat. It is
+intended for math but mathTeX is fully compatible with LaTeX and any package can
+be used and mimeTeX also supports many other features.</longdescription>
+ <upstream>
+ <remote-id type="google-code">pidgintex</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
new file mode 100644
index 000000000000..2be64a85acd9
--- /dev/null
+++ b/x11-plugins/pidgintex/pidgintex-1.1.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit toolchain-funcs multilib
+
+MY_P=pidginTeX-${PV}
+
+DESCRIPTION="Pidgin plugin to render LaTeX expressions in messages"
+HOMEPAGE="http://code.google.com/p/pidgintex"
+SRC_URI="http://pidgintex.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="net-im/pidgin[gtk]
+ app-text/mathtex"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ sed -e "s:\(^CC.*=\).*:\1 $(tc-getCC):" \
+ -e "s:\(^STRIP.*=\).*:\1 true:" \
+ -e "s:\(^CFLAGS[[:space:]]*\)=:\1+=:" \
+ -e "/LIB_INSTALL_DIR/{s:/lib/purple-2:/$(get_libdir)/pidgin:;}" \
+ -i Makefile || die
+ # set default renderer to mathtex
+ sed -e "/purple_prefs_add_string.*PREFS_RENDERER/{s:mimetex:mathtex:;}" \
+ -i pidginTeX.c || die
+}
+
+src_compile() {
+ emake PREFIX=/usr || die
+}
+
+src_install() {
+ make PREFIX="${D}/usr" install || die "make install failed"
+ dodoc CHANGELOG README TODO || die
+}
+
+pkg_postinst() {
+ elog 'Note, to see formulas either disable "Conversation Colors" plugin or'
+ elog 'switch off "ignore incoming format" option in plugin configuration.'
+ elog 'For details, take a look (and vote) at http://developer.pidgin.im/ticket/2772'
+}