summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2016-02-11 14:26:03 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2016-02-11 14:26:14 +0100
commit137cb72688c7aeb11695a59796363d9435d0e579 (patch)
tree043b535919b0939397d648461dd106bb40c328c8 /x11-plugins/wmget/wmget-0.6.1.ebuild
parentdev-ruby/backports: add 3.6.8 (diff)
downloadgentoo-137cb72688c7aeb11695a59796363d9435d0e579.tar.gz
gentoo-137cb72688c7aeb11695a59796363d9435d0e579.tar.bz2
gentoo-137cb72688c7aeb11695a59796363d9435d0e579.zip
x11-plugins/wmget: version bump with new homepage, ebuild cleanup
Package-Manager: portage-2.2.27
Diffstat (limited to 'x11-plugins/wmget/wmget-0.6.1.ebuild')
-rw-r--r--x11-plugins/wmget/wmget-0.6.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-plugins/wmget/wmget-0.6.1.ebuild b/x11-plugins/wmget/wmget-0.6.1.ebuild
new file mode 100644
index 000000000000..10628be7dcba
--- /dev/null
+++ b/x11-plugins/wmget/wmget-0.6.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="a libcurl based dockapp for automated downloads"
+HOMEPAGE="http://windowmaker.org/dockapps/?name=wmget"
+# Grab from http://windowmaker.org/dockapps/?download=${P}.tar.gz
+SRC_URI="https://dev.gentoo.org/~voyageur/distfiles/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm
+ >=net-misc/curl-7.9.7"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}