summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-plugins/wmsysmon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-plugins/wmsysmon')
-rw-r--r--x11-plugins/wmsysmon/Manifest2
-rw-r--r--x11-plugins/wmsysmon/files/wmsysmon-high-ints.patch11
-rw-r--r--x11-plugins/wmsysmon/metadata.xml9
-rw-r--r--x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild50
4 files changed, 72 insertions, 0 deletions
diff --git a/x11-plugins/wmsysmon/Manifest b/x11-plugins/wmsysmon/Manifest
new file mode 100644
index 000000000000..f5ffd1d42d91
--- /dev/null
+++ b/x11-plugins/wmsysmon/Manifest
@@ -0,0 +1,2 @@
+DIST wmsysmon-0.7.7-s4t4n.patch.bz2 8547 SHA256 b585793744c65ccc10c0b2b55c34f7c5cf0ac03b99526f50842ace99a1ce7245
+DIST wmsysmon-0.7.7.tar.gz 20866 SHA256 b50e3d834e799ff2b2a825c67534e049bed2af2c261d83b8afbbd4a9010d3e5c
diff --git a/x11-plugins/wmsysmon/files/wmsysmon-high-ints.patch b/x11-plugins/wmsysmon/files/wmsysmon-high-ints.patch
new file mode 100644
index 000000000000..4ba89fb33212
--- /dev/null
+++ b/x11-plugins/wmsysmon/files/wmsysmon-high-ints.patch
@@ -0,0 +1,11 @@
+--- Makefile 2004-08-02 13:18:22.780070984 +0200
++++ Makefile 2004-08-02 13:19:07.776230528 +0200
+@@ -3,7 +3,7 @@
+ LIBDIR += -L/usr/X11R6/lib
+ LDFLAGS += -lXpm -lXext -lX11 -lm -s
+ #CFLAGS = -g #-DMONDEBUG
+-CFLAGS += ${GENTOO_CFLAGS} -W -Wall -pedantic -I/usr/X11R6/include #-DHI_INTS #undefine HI_INTS if your x86 SMP or alpha
++CFLAGS += ${GENTOO_CFLAGS} -W -Wall -pedantic -I/usr/X11R6/include -DHI_INTS #undefine HI_INTS if your x86 SMP or alpha
+
+ BIN = wmsysmon
+ OBJS = wmgeneral.o \
diff --git a/x11-plugins/wmsysmon/metadata.xml b/x11-plugins/wmsysmon/metadata.xml
new file mode 100644
index 000000000000..720cdbbfade1
--- /dev/null
+++ b/x11-plugins/wmsysmon/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>desktop-dock</herd>
+<use>
+ <flag name='high-ints'>Enable support for monitoring 24 interrupts. Useful
+ on SMP machines</flag>
+</use>
+</pkgmetadata>
diff --git a/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild b/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild
new file mode 100644
index 000000000000..d7c292e7f852
--- /dev/null
+++ b/x11-plugins/wmsysmon/wmsysmon-0.7.7.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+IUSE="high-ints"
+DESCRIPTION="a dockapp to monitor: CPU, Memory, Uptime, IRQs, Paging and Swap activity"
+SRC_URI="http://www.gnugeneration.com/software/wmsysmon/src/${P}.tar.gz
+ mirror://gentoo/${P}-s4t4n.patch.bz2"
+HOMEPAGE="http://www.gnugeneration.com/software/wmsysmon/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="alpha amd64 ppc ppc64 sparc x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ >=sys-apps/sed-4.1.5-r1"
+
+src_unpack()
+{
+ unpack ${A}
+ cd "${S}"
+
+ # bug 48851
+ epatch "${WORKDIR}"/${P}-s4t4n.patch
+
+ # Monitor all the 24 interrupts on alpha and x86 SMP machines
+ if use alpha || use high-ints; then
+ cd src
+ epatch "${FILESDIR}"/${PN}-high-ints.patch
+ fi
+
+ # Do no strip binaries during compilation, see bug #252113
+ sed -i 's/LDFLAGS += -lXpm -lXext -lX11 -lm -s/LDFLAGS += -lXpm -lXext -lX11 -lm/' "src/Makefile"
+}
+
+src_compile()
+{
+ GENTOO_CFLAGS="${CFLAGS}" make -C src
+}
+
+src_install ()
+{
+ dobin src/wmsysmon
+ dodoc ChangeLog README
+}