summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorend222 <pabloorduna98@gmail.com>2020-07-31 15:41:47 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-08-12 10:59:40 +0300
commitd2e5337024968ab153be042b8939f80d52d81761 (patch)
tree356a2bcb5ac2acb6a220b79f788fe1f6fe42e002 /x11-terms
parentsys-cluster/kube-router: drop old (diff)
downloadgentoo-d2e5337024968ab153be042b8939f80d52d81761.tar.gz
gentoo-d2e5337024968ab153be042b8939f80d52d81761.tar.bz2
gentoo-d2e5337024968ab153be042b8939f80d52d81761.zip
x11-terms/kitty-terminfo: fix live ebuild
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://bugs.gentoo.org/734720 Closes: https://github.com/gentoo/gentoo/pull/16917 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch46
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild2
2 files changed, 47 insertions, 1 deletions
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch
new file mode 100644
index 000000000000..ae6f087069c7
--- /dev/null
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch
@@ -0,0 +1,46 @@
+diff --git a/setup.py b/setup.py
+index 7c4295bd..8d31e2d1 100755
+--- a/setup.py
++++ b/setup.py
+@@ -856,6 +856,14 @@ Categories=System;TerminalEmulator;
+ os.makedirs(os.path.dirname(in_src_launcher), exist_ok=True)
+ os.symlink(os.path.relpath(launcher, os.path.dirname(in_src_launcher)), in_src_launcher)
+
++def terminfo(args):
++ ddir = args.prefix
++ libdir = os.path.join(ddir, args.libdir_name.strip('/'), 'kitty')
++ build_terminfo = runpy.run_path('build-terminfo', run_name='import_build')
++ for x in (libdir, os.path.join(ddir, 'share')):
++ odir = os.path.join(x, 'terminfo')
++ safe_makedirs(odir)
++ build_terminfo['compile_terminfo'](odir)
+
+ def macos_info_plist() -> bytes:
+ import plistlib
+@@ -1022,7 +1030,7 @@ def clean() -> None:
+
+ safe_remove(
+ 'build', 'compile_commands.json', 'link_commands.json',
+- 'linux-package', 'kitty.app', 'asan-launcher',
++ 'linux-package', 'linux-terminfo', 'kitty.app', 'asan-launcher',
+ 'kitty-profile', 'kitty/launcher')
+ exclude = ('.git',)
+ for root, dirs, files in os.walk('.', topdown=True):
+@@ -1045,7 +1053,7 @@ def option_parser() -> argparse.ArgumentParser: # {{{
+ 'action',
+ nargs='?',
+ default=Options.action,
+- choices='build test linux-package kitty.app linux-freeze macos-freeze build-launcher clean'.split(),
++ choices='build test linux-package linux-terminfo kitty.app linux-freeze macos-freeze build-launcher clean'.split(),
+ help='Action to perform (default is build)'
+ )
+ p.add_argument(
+@@ -1166,6 +1174,8 @@ def main() -> None:
+ elif args.action == 'linux-package':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-package')
++ elif args.action == 'linux-terminfo':
++ terminfo(args)
+ elif args.action == 'linux-freeze':
+ build(args, native_optimizations=False)
+ package(args, bundle_type='linux-freeze')
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
index b43704ce0df0..6e6b7a4abe73 100644
--- a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
@@ -18,7 +18,7 @@ IUSE="debug"
DEPEND="${PYTHON_DEPS}"
PATCHES=(
- "${FILESDIR}"/kitty-terminfo-setup-0.17.2.patch
+ "${FILESDIR}"/kitty-terminfo-setup-9999.patch
)
# kitty-terminfo is a split package from kitty that only installs the terminfo