summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2025-01-12 11:23:11 +0200
committerJoonas Niilola <juippis@gentoo.org>2025-01-12 11:29:52 +0200
commit7a44ddfc39ffd010426f3ecfa94ae0abe5defca1 (patch)
tree238c3f67d2f3173844069d03abe0c96b20ceacf2 /x11-wm
parentdev-libs/efl: add 1.28.0 (diff)
downloadgentoo-7a44ddfc39ffd010426f3ecfa94ae0abe5defca1.tar.gz
gentoo-7a44ddfc39ffd010426f3ecfa94ae0abe5defca1.tar.bz2
gentoo-7a44ddfc39ffd010426f3ecfa94ae0abe5defca1.zip
x11-wm/enlightenment: add 0.27.0
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Manifest1
-rw-r--r--x11-wm/enlightenment/enlightenment-0.27.0.ebuild119
2 files changed, 120 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index b61c009486e7..426a219ddfa6 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -1 +1,2 @@
DIST enlightenment-0.26.0.tar.xz 409678784 BLAKE2B e03cb4485fafd3b03a69ca20b5910fc5b0d7070b625a5f9f6c365d57b62b6be00f7c370f38e127e92f29e430045c3502e7868219cb246f84f044d418808a3ae1 SHA512 52a656b397348a4f6baa28b9da4b42c81160b06d28dba58c22bdf00bf749aed3a9b194e171a5ac349745a4c11afc8ae8c38f9bf8c31bacbc0d196cfb24b15a1e
+DIST enlightenment-0.27.0.tar.xz 409707052 BLAKE2B 9ba22bc619eaf424794dfd34304be9fca205d27b3e318d0dc1d8a126c72174e4a4d71923bdd63076d8984641041bc69fe50b0646299c112f9ce221eb8afe7ff2 SHA512 cd4cad76a4a7e63d4f5f05fb4664580dbb4fb19b2aff059a3c2b32bdcd2495a87eea0a373ed67bc844aa4e4600ad62a0a0de995896a0eda8fb5857590a2affc5
diff --git a/x11-wm/enlightenment/enlightenment-0.27.0.ebuild b/x11-wm/enlightenment/enlightenment-0.27.0.ebuild
new file mode 100644
index 000000000000..31b82776b33f
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.27.0.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson optfeature xdg
+
+DESCRIPTION="Enlightenment window manager"
+HOMEPAGE="https://www.enlightenment.org"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+
+# Historically enlightenment was slotted to separate e16 from e17. e16 is now
+# packaged as x11-wm/e16, but the slot is kept because it's more complicated to
+# reset it rather than just to keep it.
+SLOT="0.17/${PV%%_*}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="acpi bluetooth connman doc exif geolocation nls pam policykit systemd udisks wayland xwayland"
+
+REQUIRED_USE="xwayland? ( wayland )"
+
+RDEPEND=">=dev-libs/efl-1.28.0[eet,fontconfig,sound,X]
+ virtual/udev
+ x11-libs/libXext
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ x11-misc/xkeyboard-config
+ acpi? ( sys-power/acpid )
+ bluetooth? ( net-wireless/bluez )
+ connman? ( dev-libs/efl[connman] )
+ exif? ( media-libs/libexif )
+ geolocation? ( app-misc/geoclue:2.0 )
+ pam? ( sys-libs/pam )
+ policykit? ( sys-auth/polkit )
+ systemd? ( sys-apps/systemd )
+ udisks? ( sys-fs/udisks:2 )
+ wayland? (
+ || (
+ dev-libs/efl[systemd]
+ dev-libs/efl[elogind]
+ )
+ dev-libs/efl[drm,wayland]
+ dev-libs/wayland
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ )
+ xwayland? (
+ dev-libs/efl[X,wayland]
+ x11-base/xwayland
+ )"
+BDEPEND="virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local emesonargs=(
+ -Dconvertible=true
+ -Ddevice-udev=true
+ -Delput=true
+ -Dinstall-enlightenment-menu=true
+
+ -Dinstall-sysactions=true
+ -Dinstall-system=true
+ -Dmount-eeze=false
+
+ -Dpackagekit=false
+
+ $(meson_use udisks mount-udisks)
+ $(meson_use bluetooth bluez5)
+ $(meson_use connman)
+ $(meson_use exif libexif)
+ $(meson_use geolocation)
+ $(meson_use nls)
+ $(meson_use pam)
+ $(meson_use policykit polkit)
+ $(meson_use systemd)
+ $(meson_use wayland wl)
+ $(meson_use xwayland)
+ )
+
+ if ! use wayland; then
+ emesonargs+=(
+ -Dwl-buffer=false
+ -Dwl-desktop-shell=false
+ -Dwl-drm=false
+ -Dwl-text-input=false
+ -Dwl-weekeyboard=false
+ -Dwl-wl=false
+ -Dwl-x11=false
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ use doc && local HTML_DOCS=( doc/. )
+ meson_src_install
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+
+ optfeature_header "Additional programs to complement the full EFL suite:"
+ optfeature "efl-based pinentry interface" app-crypt/pinentry[efl]
+ optfeature "an efl-based text editor" app-editors/ecrire
+ optfeature "better monitor backlight and brightness controls" app-misc/ddcutil
+ optfeature "office file thumbnails" app-office/libreoffice app-office/libreoffice-bin
+ optfeature "an EFL-based IDE" dev-util/edi
+ optfeature "image viewer" media-gfx/entice
+ optfeature "image viewer" media-gfx/ephoto
+ optfeature "a media player" media-video/rage
+ optfeature "system and process monitor" sys-process/evisum
+ optfeature "feature rich terminal emulator" x11-terms/terminology
+ optfeature "a matching GTK theme" x11-themes/e-gtk-theme
+}