summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-gfx/sam2p/files/sam2p-0.49.4_p20190718-fix-configure-clang.patch15
-rw-r--r--media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild7
2 files changed, 20 insertions, 2 deletions
diff --git a/media-gfx/sam2p/files/sam2p-0.49.4_p20190718-fix-configure-clang.patch b/media-gfx/sam2p/files/sam2p-0.49.4_p20190718-fix-configure-clang.patch
new file mode 100644
index 000000000000..0d8e769e903d
--- /dev/null
+++ b/media-gfx/sam2p/files/sam2p-0.49.4_p20190718-fix-configure-clang.patch
@@ -0,0 +1,15 @@
+https://bugs.gentoo.org/827925
+--- a/configure.in
++++ b/configure.in
+@@ -79,11 +79,11 @@ else
+ fi
+
+ dnl Checks for programs.
+ dnl AC_PROG_CC
+ AC_LANG_CPLUSPLUS
+-CXXFLAGS=" "
++CXXFLAGS="-fPIC"
+ dnl ^^^ set it to non-empty, so AC_PROG_CXX won't include `-g'
+ CCC="$CCC g++"
+ dnl ^^^ check g++ before c++ (see acspecific.m4, grep AC_PROG_CXX)
+ AC_PROG_CXX
diff --git a/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild b/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild
index 43f217aba10d..3adddb11fdbc 100644
--- a/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild
+++ b/media-gfx/sam2p/sam2p-0.49.4_p20190718-r1.ebuild
@@ -21,7 +21,10 @@ BDEPEND="dev-lang/perl"
S="${WORKDIR}/${PN}-${COMMIT}"
-PATCHES=( "${FILESDIR}"/${PN}-build-fixes.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-build-fixes.patch
+ "${FILESDIR}"/${PN}-0.49.4_p20190718-fix-configure-clang.patch
+)
src_prepare() {
default
@@ -30,7 +33,7 @@ src_prepare() {
mv configure.{in,ac} || die
# missing include for memset
- sed -i '1s;^;#include <string.h>\n;' pts_defl.c
+ sed -i '1s;^;#include <string.h>\n;' pts_defl.c || die
# eautoreconf is still needed or you get bad warnings
eautoreconf