summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/funcparserlib/funcparserlib-0.3.6.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild b/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
deleted file mode 100644
index e69253e20800..000000000000
--- a/dev-python/funcparserlib/funcparserlib-0.3.6.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="Recursive descent parsing library based on functional combinators"
-HOMEPAGE="https://pypi.org/project/funcparserlib/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_test() {
- local m=unittest
- cd "${BUILD_DIR}"/lib || die
- "${PYTHON}" -m ${m} discover || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- local DOCS=( doc/*.md )
- distutils-r1_python_install_all
-}