summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libltc/Manifest1
-rw-r--r--media-libs/libltc/libltc-1.3.2.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/media-libs/libltc/Manifest b/media-libs/libltc/Manifest
index 97ae3d630a04..1daead03a70e 100644
--- a/media-libs/libltc/Manifest
+++ b/media-libs/libltc/Manifest
@@ -1 +1,2 @@
DIST libltc-1.3.1.tar.gz 440790 BLAKE2B 881a237a23e6f4a9d058d69b26cad78c96a9dc0f90bb5b5ffc2d08f4b894d039b57e53cb70844d89b0defa5795d252e3afef07d43bfd4dc8b10a34066b6c1efe SHA512 e4ba96560f04155d022d2c975fa36d4bb77efb9a877344041e1bd12bd5e7d04dccb452f3a4e061aba961bd0c3c0d1d53dc98ac469e04e61a934feeedc20e09b3
+DIST libltc-1.3.2.tar.gz 449921 BLAKE2B 8a6b3452245f72e918b4a105854d751ca66780ce4627aca54bb0d1342c5a1e77e614103da15037f71b89d44c62b35230a6240e42af287c442e6049c2ad9c85a6 SHA512 3b29b7da1ad9f85c62068b927abec9b3963a77558b46b3ee7681f360642570935becedcf95436574a8a7b456c7e0b414131571d71c6903139f9e7565968278a6
diff --git a/media-libs/libltc/libltc-1.3.2.ebuild b/media-libs/libltc/libltc-1.3.2.ebuild
new file mode 100644
index 000000000000..a713d30f5e04
--- /dev/null
+++ b/media-libs/libltc/libltc-1.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Linear/Logitudinal Time Code (LTC) Library"
+HOMEPAGE="https://github.com/x42/libltc.git"
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3 autotools
+ EGIT_REPO_URI="https://github.com/x42/libltc.git"
+else
+ SRC_URI="https://github.com/x42/libltc/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+LICENSE="LGPL-3"
+SLOT="0"
+RESTRICT="mirror"
+
+src_prepare() {
+ default
+
+ [[ ${PV} == *9999 ]] && eautoreconf
+}
+
+src_install() {
+ default
+ find "${ED}" \( -name "*.a" -o -name "*.la" \) -delete || die
+}