summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-servers/monkeyd/monkeyd-1.6.9-r1.ebuild10
-rw-r--r--www-servers/monkeyd/monkeyd-9999.ebuild8
2 files changed, 9 insertions, 9 deletions
diff --git a/www-servers/monkeyd/monkeyd-1.6.9-r1.ebuild b/www-servers/monkeyd/monkeyd-1.6.9-r1.ebuild
index 67bcf7351327..d86b0157384e 100644
--- a/www-servers/monkeyd/monkeyd-1.6.9-r1.ebuild
+++ b/www-servers/monkeyd/monkeyd-1.6.9-r1.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=5
inherit eutils flag-o-matic toolchain-funcs user multilib
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
MY_P="${PN/d}-${PV}"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/monkey/monkey.git"
- inherit git-2
- KEYWORDS="amd64 arm ppc64"
+ inherit git-r3
+ KEYWORDS=""
else
SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"
KEYWORDS="amd64 arm ~mips ppc ppc64 x86"
diff --git a/www-servers/monkeyd/monkeyd-9999.ebuild b/www-servers/monkeyd/monkeyd-9999.ebuild
index fafdebcfb419..86d571f41378 100644
--- a/www-servers/monkeyd/monkeyd-9999.ebuild
+++ b/www-servers/monkeyd/monkeyd-9999.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI=5
inherit eutils flag-o-matic toolchain-funcs user multilib
DESCRIPTION="A small, fast, and scalable web server"
HOMEPAGE="http://www.monkey-project.com/"
MY_P="${PN/d}-${PV}"
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == *9999* ]] ; then
EGIT_REPO_URI="https://github.com/monkey/monkey.git"
- inherit git-2
+ inherit git-r3
KEYWORDS=""
else
SRC_URI="http://monkey-project.com/releases/${PV:0:3}/${MY_P}.tar.gz"