summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/ee/ee-1.4.6.ebuild')
-rw-r--r--app-editors/ee/ee-1.4.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-editors/ee/ee-1.4.6.ebuild b/app-editors/ee/ee-1.4.6.ebuild
new file mode 100644
index 000000000000..14abfe287ad3
--- /dev/null
+++ b/app-editors/ee/ee-1.4.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="An easy to use text editor. Intended to be usable with little or no instruction"
+HOMEPAGE="http://mahon.cwx.net/"
+SRC_URI="http://mahon.cwx.net/sources/${P}.src.tgz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~mips ppc ppc64 ~sparc x86"
+IUSE=""
+
+RDEPEND="!app-editors/ersatz-emacs"
+S="${WORKDIR}/easyedit-${PV}"
+
+src_prepare() {
+ sed -i \
+ -e "s/\tcc /\t\\\\\$(CC) /" \
+ -e "/other_cflag/s/ *-s//" \
+ create.make
+}
+
+src_configure() {
+ emake localmake
+}
+
+src_compile() {
+ emake -f make.local CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ee
+ doman ee.1
+ dodoc Changes README.ee ee.i18n.guide ee.msg
+}