summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gummi')
-rw-r--r--app-editors/gummi/Manifest1
-rw-r--r--app-editors/gummi/gummi-0.6.5.ebuild46
-rw-r--r--app-editors/gummi/gummi-9999.ebuild46
-rw-r--r--app-editors/gummi/metadata.xml18
4 files changed, 111 insertions, 0 deletions
diff --git a/app-editors/gummi/Manifest b/app-editors/gummi/Manifest
new file mode 100644
index 000000000000..1f55505fae7e
--- /dev/null
+++ b/app-editors/gummi/Manifest
@@ -0,0 +1 @@
+DIST gummi-0.6.5.tar.gz 520902 SHA256 b23c2958376ea43c701a276ad19ceac5b50d9cb32a489a10897b25aa5004fffb SHA512 9a35533273ff5f2606ba1d79c01dcdf14f2a47628eb5d19613330650ed2a2bd542461492d031e51b773e13c6ac406b564e6703919f16e5f8d7e6bb3c4428b40e WHIRLPOOL 47e1ad5a15183ed0d24a88ebc3bc1af166604825da54db10461243ba4c1b8d6ca82d1afaf7306ef45a4df0f65d103b6cbc83db02cb6469fb7138545e16ae2728
diff --git a/app-editors/gummi/gummi-0.6.5.ebuild b/app-editors/gummi/gummi-0.6.5.ebuild
new file mode 100644
index 000000000000..20ec5c8258a8
--- /dev/null
+++ b/app-editors/gummi/gummi-0.6.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit base eutils readme.gentoo
+
+DESCRIPTION="Simple LaTeX editor for GTK+"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/attachments/download/301/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+LANGS="ar ca cs da de el es fr hu it nl pl pt pt_BR ro ru sv zh_CN zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell:2
+ >=dev-libs/glib-2.28.6
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.24:2
+ x11-libs/gtksourceview:2.0"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+ DOC_CONTENTS="Gummi supports spell-checking through gtkspell. Support for
+ additional languages can be added by installing myspell-** packages
+ for your language of choice."
+}
+
+src_install() {
+ base_src_install
+ readme.gentoo_create_doc
+}
diff --git a/app-editors/gummi/gummi-9999.ebuild b/app-editors/gummi/gummi-9999.ebuild
new file mode 100644
index 000000000000..8c828bb39337
--- /dev/null
+++ b/app-editors/gummi/gummi-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit autotools base eutils subversion
+
+ESVN_REPO_URI="http://svn.midnightcoding.org/gummi/trunk"
+ESVN_PROJECT="${PN/-svn}"
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS=""
+IUSE=""
+
+LANGS="ca da de fr el it nl pt_BR ru zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.16:2"
+DEPEND="${RDEPEND}
+ app-text/gtkspell:2
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+ eautoreconf
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}
diff --git a/app-editors/gummi/metadata.xml b/app-editors/gummi/metadata.xml
new file mode 100644
index 000000000000..8356a1fe2cad
--- /dev/null
+++ b/app-editors/gummi/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+<email>alexvandermey@gmail.com</email>
+<name>Alexander van der Mey</name>
+<description>Upstream developer.</description>
+</maintainer>
+<maintainer>
+<email>hwoarang@gentoo.org</email>
+<name>Markos Chandras</name>
+<description>Proxy maintainer.</description>
+</maintainer>
+<longdescription lang="en">
+</longdescription>
+</pkgmetadata>
+