summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/simh/simh-3.8.1.ebuild')
-rw-r--r--app-emulation/simh/simh-3.8.1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/app-emulation/simh/simh-3.8.1.ebuild b/app-emulation/simh/simh-3.8.1.ebuild
deleted file mode 100644
index 8cc23cddc6f9..000000000000
--- a/app-emulation/simh/simh-3.8.1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-inherit eutils toolchain-funcs versionator
-
-MY_P="${PN}v$(get_version_component_range 1)$(get_version_component_range 2)-$(get_version_component_range 3)"
-DESCRIPTION="a simulator for historical computers such as Vax, PDP-11 etc.)"
-HOMEPAGE="http://simh.trailing-edge.com/"
-SRC_URI="http://simh.trailing-edge.com/sources/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
-IUSE=""
-
-RDEPEND="net-libs/libpcap"
-DEPEND="${RDEPEND}
- app-arch/unzip"
-
-S=${WORKDIR}
-
-MAKEOPTS="USE_NETWORK=1 ${MAKEOPTS}"
-
-src_unpack() {
- mkdir "${WORKDIR}/BIN"
- unpack ${A}
-
- # convert makefile from dos format to unix format
- edos2unix makefile
-
- epatch "${FILESDIR}/${P}-makefile.patch" \
- "${FILESDIR}/${P}-asneeded.patch"
-
- # fix linking on Darwin
- [[ ${CHOST} == *-darwin* ]] && sed -i 's/-lrt//g' makefile
-}
-
-src_compile() {
- tc-export CC
- emake || die "make failed"
-}
-
-src_install() {
- cd "${S}/BIN"
- for BINFILE in *; do
- newbin ${BINFILE} "simh-${BINFILE}"
- done
-
- cd "${S}"
- dodir /usr/share/simh
- insinto /usr/share/simh
- doins VAX/*.bin
- dodoc *.txt */*.txt
-}