summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/wine')
-rw-r--r--app-emulation/wine/metadata.xml1
-rw-r--r--app-emulation/wine/wine-1.9.19-r1.ebuild (renamed from app-emulation/wine/wine-1.9.19.ebuild)4
-rw-r--r--app-emulation/wine/wine-9999.ebuild4
3 files changed, 7 insertions, 2 deletions
diff --git a/app-emulation/wine/metadata.xml b/app-emulation/wine/metadata.xml
index 02c8686f56b4..309f99b26840 100644
--- a/app-emulation/wine/metadata.xml
+++ b/app-emulation/wine/metadata.xml
@@ -40,6 +40,7 @@ Think of Wine as a compatibility layer for running Windows programs. Wine does n
http://wiki.winehq.org/NtlmSigningAndSealing</flag>
<flag name="staging">Apply Wine-Staging patches for advanced feature support that haven't made it into upstream Wine yet</flag>
<flag name="themes">Support GTK+:3 window theming through Wine-Staging</flag>
+ <flag name="udev">Use <pkg>virtual/libudev</pkg> to provide plug and play support</flag>
</use>
<upstream>
<remote-id type="github">wine-compholio/wine-staging</remote-id>
diff --git a/app-emulation/wine/wine-1.9.19.ebuild b/app-emulation/wine/wine-1.9.19-r1.ebuild
index 3e02ff406aa6..bad015a40b5a 100644
--- a/app-emulation/wine/wine-1.9.19.ebuild
+++ b/app-emulation/wine/wine-1.9.19-r1.ebuild
@@ -61,7 +61,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner selinux +ssl staging test themes +threads +truetype +udisks v4l vaapi +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -127,6 +127,7 @@ COMMON_DEPEND="
x11-libs/gtk+:3[${MULTILIB_USEDEP}]
)
truetype? ( >=media-libs/freetype-2.0.0[${MULTILIB_USEDEP}] )
+ udev? ( virtual/libudev:=[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
vaapi? ( x11-libs/libva[X,${MULTILIB_USEDEP}] )
@@ -428,6 +429,7 @@ multilib_src_configure() {
$(use_with scanner sane)
$(use_enable test tests)
$(use_with truetype freetype)
+ $(use_with udev)
$(use_with v4l)
$(use_with X x)
$(use_with xcomposite)
diff --git a/app-emulation/wine/wine-9999.ebuild b/app-emulation/wine/wine-9999.ebuild
index 3e02ff406aa6..bad015a40b5a 100644
--- a/app-emulation/wine/wine-9999.ebuild
+++ b/app-emulation/wine/wine-9999.ebuild
@@ -61,7 +61,7 @@ fi
LICENSE="LGPL-2.1"
SLOT="0"
-IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner selinux +ssl staging test themes +threads +truetype +udisks v4l vaapi +X +xcomposite xinerama +xml"
+IUSE="+abi_x86_32 +abi_x86_64 +alsa capi cups custom-cflags d3d9 dos elibc_glibc +fontconfig +gecko gphoto2 gsm gstreamer +jpeg kernel_FreeBSD +lcms ldap +mono mp3 ncurses netapi nls odbc openal opencl +opengl osmesa oss +perl pcap pipelight +png prelink pulseaudio +realtime +run-exes s3tc samba scanner selinux +ssl staging test themes +threads +truetype udev +udisks v4l vaapi +X +xcomposite xinerama +xml"
REQUIRED_USE="|| ( abi_x86_32 abi_x86_64 )
X? ( truetype )
elibc_glibc? ( threads )
@@ -127,6 +127,7 @@ COMMON_DEPEND="
x11-libs/gtk+:3[${MULTILIB_USEDEP}]
)
truetype? ( >=media-libs/freetype-2.0.0[${MULTILIB_USEDEP}] )
+ udev? ( virtual/libudev:=[${MULTILIB_USEDEP}] )
udisks? ( sys-apps/dbus[${MULTILIB_USEDEP}] )
v4l? ( media-libs/libv4l[${MULTILIB_USEDEP}] )
vaapi? ( x11-libs/libva[X,${MULTILIB_USEDEP}] )
@@ -428,6 +429,7 @@ multilib_src_configure() {
$(use_with scanner sane)
$(use_enable test tests)
$(use_with truetype freetype)
+ $(use_with udev)
$(use_with v4l)
$(use_with X x)
$(use_with xcomposite)