summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/testtools/testtools-2.5.0-r1.ebuild')
-rw-r--r--dev-python/testtools/testtools-2.5.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-python/testtools/testtools-2.5.0-r1.ebuild b/dev-python/testtools/testtools-2.5.0-r1.ebuild
index 5b4ff96df657..a6fe6fe82954 100644
--- a/dev-python/testtools/testtools-2.5.0-r1.ebuild
+++ b/dev-python/testtools/testtools-2.5.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
@@ -41,8 +41,13 @@ PDEPEND="
distutils_enable_sphinx doc
+PATCHES=(
+ # https://github.com/testing-cabal/testtools/pull/328
+ "${FILESDIR}"/${P}-py311.patch
+)
+
src_prepare() {
- # very fragile to formatting changes
+ # very fragile to formatting changes (broken on py3.10 & pypy3)
sed -i -e 's:test_syntax_error(:_&:' \
testtools/tests/test_testresult.py || die