summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild')
-rw-r--r--dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild
new file mode 100644
index 000000000000..97bbaad2eb7d
--- /dev/null
+++ b/dev-ros/rqt_tf_tree/rqt_tf_tree-0.6.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+KEYWORDS="~amd64"
+ROS_REPO_URI="https://github.com/ros-visualization/rqt_tf_tree"
+
+inherit ros-catkin
+
+DESCRIPTION="GUI plugin for visualizing the ROS TF frame tree"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/geometry_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-python/rospkg[${PYTHON_USEDEP}]
+ dev-ros/qt_dotgraph[${PYTHON_USEDEP}]
+ dev-ros/rospy[${PYTHON_USEDEP}]
+ dev-ros/rqt_graph[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui[${PYTHON_USEDEP}]
+ dev-ros/rqt_gui_py[${PYTHON_USEDEP}]
+ dev-ros/tf2
+ dev-ros/tf2_msgs[${CATKIN_MESSAGES_PYTHON_USEDEP}]
+ dev-ros/tf2_ros[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+PATCHES=( "${FILESDIR}/yaml.patch" )