summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros')
-rw-r--r--dev-ros/nodelet_tutorial_math/Manifest1
-rw-r--r--dev-ros/nodelet_tutorial_math/metadata.xml5
-rw-r--r--dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-0.1.8.ebuild22
-rw-r--r--dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-9999.ebuild22
4 files changed, 50 insertions, 0 deletions
diff --git a/dev-ros/nodelet_tutorial_math/Manifest b/dev-ros/nodelet_tutorial_math/Manifest
new file mode 100644
index 000000000000..c0f80a822bb9
--- /dev/null
+++ b/dev-ros/nodelet_tutorial_math/Manifest
@@ -0,0 +1 @@
+DIST common_tutorials-0.1.8.tar.gz 10591 SHA256 5be04cdcfbc569d7b89c306628fd4414a3e2972ad2154548df2b86d4056393d9 SHA512 a0a2e8a7aba3415bf133e95e7d1b72cf5ee81efa962003ccaa2108fdfebd2a03044c60fd4daf73ca69f3a2975bd7fa9c60adfefc32d1b048da11e65aa613607c WHIRLPOOL dd60f2c2c760c4f3485ec670af0a0140569535640886268f329e6088fa19279703489b361d51ba9bbd8cb05194f63376b11983e1709e1f5063dc6e28453a0685
diff --git a/dev-ros/nodelet_tutorial_math/metadata.xml b/dev-ros/nodelet_tutorial_math/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/nodelet_tutorial_math/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-0.1.8.ebuild b/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-0.1.8.ebuild
new file mode 100644
index 000000000000..6ea618aa6793
--- /dev/null
+++ b/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-0.1.8.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelet tutorial"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-9999.ebuild b/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-9999.ebuild
new file mode 100644
index 000000000000..6ea618aa6793
--- /dev/null
+++ b/dev-ros/nodelet_tutorial_math/nodelet_tutorial_math-9999.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/common_tutorials"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Nodelet tutorial"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/nodelet
+ dev-ros/roscpp
+ dev-ros/std_msgs[${CATKIN_MESSAGES_CXX_USEDEP}]
+"
+DEPEND="${RDEPEND}"