summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/timers')
-rw-r--r--dev-ruby/timers/Manifest1
-rw-r--r--dev-ruby/timers/metadata.xml8
-rw-r--r--dev-ruby/timers/timers-4.0.1.ebuild37
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/timers/Manifest b/dev-ruby/timers/Manifest
new file mode 100644
index 000000000000..aad60dc92d59
--- /dev/null
+++ b/dev-ruby/timers/Manifest
@@ -0,0 +1 @@
+DIST timers-4.0.1.gem 14848 SHA256 f45ca1b8ce6b26e29226c2144c512801a9019c3e781054d878c205cb0fd8500d SHA512 4fb0b70d845885bd1863831795b4094a5e282797641cbe95045ed013a5b5caa404da6ed60a148e3c313988c5acdf0042b0021dd476585f5032099895aaef283d WHIRLPOOL 6c33918e5b685dbee889657bf202b71575ece24797b8c629ac27433905e0505c72fe1f15fc75975d35a4e5ddc75e18a2b0aa0626132c5dec8f91daed23bad6db
diff --git a/dev-ruby/timers/metadata.xml b/dev-ruby/timers/metadata.xml
new file mode 100644
index 000000000000..c59b87b6f503
--- /dev/null
+++ b/dev-ruby/timers/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <upstream>
+ <remote-id type="github">tarcieri/timers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/timers/timers-4.0.1.ebuild b/dev-ruby/timers/timers-4.0.1.ebuild
new file mode 100644
index 000000000000..33b904bf3c56
--- /dev/null
+++ b/dev-ruby/timers/timers-4.0.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby19 ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Pure Ruby one-shot and periodic timers"
+HOMEPAGE="https://github.com/tarcieri/timers"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend "dev-ruby/hitimes"
+
+all_ruby_prepare() {
+ rm Gemfile || die
+ sed -i -e '/bundler/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/coveralls/ s:^:#:' spec/spec_helper.rb || die
+ sed -i -e '/Coveralls/ s:^:#:' spec/spec_helper.rb || die
+
+ # Remove performance spec due to dependencies and being to dependent
+ # on machine specifics.
+ rm spec/performance_spec.rb
+
+ # Remove rspec3 configuration so we can still run with rspec2.
+ sed -e '/expose/ s:^:#:' -i spec/spec_helper.rb || die
+}