summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/x265/x265-1.8.ebuild')
-rw-r--r--media-libs/x265/x265-1.8.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/media-libs/x265/x265-1.8.ebuild b/media-libs/x265/x265-1.8.ebuild
index 8138afcc4b0e..d5b67b240d17 100644
--- a/media-libs/x265/x265-1.8.ebuild
+++ b/media-libs/x265/x265-1.8.ebuild
@@ -22,7 +22,7 @@ HOMEPAGE="http://x265.org/"
LICENSE="GPL-2"
# subslot = libx265 soname
SLOT="0/68"
-IUSE="+10bit test"
+IUSE="+10bit pic test"
ASM_DEPEND=">=dev-lang/yasm-1.2.0"
RDEPEND=""
@@ -58,6 +58,11 @@ multilib_src_configure() {
if [[ ${ABI} = x86 ]] ; then
use 10bit && ewarn "Disabling 10bit support on x86 as it does not build (or requires to disable assembly optimizations)"
mycmakeargs+=( -DHIGH_BIT_DEPTH=OFF )
+ # Bug #528202
+ if use pic ; then
+ ewarn "PIC has been requested but x86 asm is not PIC-safe, disabling it."
+ mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )
+ fi
elif [[ ${ABI} = x32 ]] ; then
# bug #510890
mycmakeargs+=( -DENABLE_ASSEMBLY=OFF )