summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/linkchecker/files')
-rw-r--r--net-analyzer/linkchecker/files/7.0-unbundle.patch28
-rw-r--r--net-analyzer/linkchecker/files/7.4-missing-files.patch13
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch28
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-8.3-unbundle.patch28
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-8.4-help.patch36
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch30
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.3-bash-completion.patch21
-rw-r--r--net-analyzer/linkchecker/files/linkchecker-9.3-desktop.patch34
8 files changed, 218 insertions, 0 deletions
diff --git a/net-analyzer/linkchecker/files/7.0-unbundle.patch b/net-analyzer/linkchecker/files/7.0-unbundle.patch
new file mode 100644
index 000000000000..74b9d11c26e9
--- /dev/null
+++ b/net-analyzer/linkchecker/files/7.0-unbundle.patch
@@ -0,0 +1,28 @@
+ setup.py | 7 -------
+ 1 files changed, 0 insertions(+), 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 8eace2a..e6aaf68 100644
+--- a/setup.py
++++ b/setup.py
+@@ -754,9 +754,6 @@ o a (Fast)CGI web interface (requires HTTP server)
+ 'py2app': MyPy2app,
+ 'register': MyRegister,
+ },
+- package_dir = {
+- 'dns': 'third_party/dnspython/dns',
+- },
+ packages = [
+ 'linkcheck',
+ 'linkcheck.bookmarks',
+@@ -769,10 +766,6 @@ o a (Fast)CGI web interface (requires HTTP server)
+ 'linkcheck.HtmlParser',
+ 'linkcheck.logger',
+ 'linkcheck.network',
+- 'dns',
+- 'dns.rdtypes',
+- 'dns.rdtypes.ANY',
+- 'dns.rdtypes.IN',
+ ],
+ ext_modules = [
+ Extension('linkcheck.HtmlParser.htmlsax',
diff --git a/net-analyzer/linkchecker/files/7.4-missing-files.patch b/net-analyzer/linkchecker/files/7.4-missing-files.patch
new file mode 100644
index 000000000000..cb8e44ad5919
--- /dev/null
+++ b/net-analyzer/linkchecker/files/7.4-missing-files.patch
@@ -0,0 +1,13 @@
+diff --git a/setup.py b/setup.py
+index 38b4c15..716203d 100755
+--- a/setup.py
++++ b/setup.py
+@@ -375,7 +375,7 @@ myemail = "calvin@users.sourceforge.net"
+ data_files = [
+ ('share/linkchecker',
+ ['config/linkcheckerrc',
+- 'doc/html/lccollection.qhc', 'doc/html/lcdoc.qch']),
++ 'doc/html/lccollection.qhcp', 'doc/html/lcdoc.qhp']),
+ ('share/linkchecker/examples',
+ ['cgi-bin/lconline/leer.html.en',
+ 'cgi-bin/lconline/leer.html.de',
diff --git a/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch b/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch
new file mode 100644
index 000000000000..dc07637e0fac
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-8.0-desktop.patch
@@ -0,0 +1,28 @@
+ doc/linkchecker-gui.desktop | 2 +-
+ doc/linkchecker.desktop | 4 ++--
+ 2 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/linkchecker-gui.desktop b/doc/linkchecker-gui.desktop
+index 7e06b6e..1b3988f 100644
+--- a/doc/linkchecker-gui.desktop
++++ b/doc/linkchecker-gui.desktop
+@@ -6,5 +6,5 @@ Version=1.0
+ Type=Application
+ Exec=linkchecker-gui
+ Terminal=false
+-Categories=Network;WebDevelopment
++Categories=Network;WebDevelopment;
+ Icon=logo48x48
+diff --git a/doc/linkchecker.desktop b/doc/linkchecker.desktop
+index 0c0617c..7a88405 100644
+--- a/doc/linkchecker.desktop
++++ b/doc/linkchecker.desktop
+@@ -5,6 +5,6 @@ GenericName[de]=URL Validator
+ Version=1.0
+ Type=Application
+ Exec=linkchecker
+-Terminal=True
+-Categories=Network;WebDevelopment
++Terminal=true
++Categories=Network;WebDevelopment;
+ Icon=logo48x48
diff --git a/net-analyzer/linkchecker/files/linkchecker-8.3-unbundle.patch b/net-analyzer/linkchecker/files/linkchecker-8.3-unbundle.patch
new file mode 100644
index 000000000000..558bb2710d96
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-8.3-unbundle.patch
@@ -0,0 +1,28 @@
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+index 36c2536..99fdf08 100644
+--- a/setup.py
++++ b/setup.py
+@@ -898,9 +898,6 @@ o a command line, GUI and web interface
+ 'py2app': MyPy2app,
+ 'register': MyRegister,
+ },
+- package_dir = {
+- 'linkcheck_dns.dns': 'third_party/dnspython/dns',
+- },
+ packages = [
+ 'linkcheck',
+ 'linkcheck.bookmarks',
+@@ -913,10 +910,6 @@ o a command line, GUI and web interface
+ 'linkcheck.HtmlParser',
+ 'linkcheck.logger',
+ 'linkcheck.network',
+- 'linkcheck_dns.dns',
+- 'linkcheck_dns.dns.rdtypes',
+- 'linkcheck_dns.dns.rdtypes.ANY',
+- 'linkcheck_dns.dns.rdtypes.IN',
+ ],
+ ext_modules = [
+ Extension('linkcheck.HtmlParser.htmlsax',
diff --git a/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch b/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch
new file mode 100644
index 000000000000..32360b6ea89e
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-8.4-help.patch
@@ -0,0 +1,36 @@
+From a7c1cdd6f69a1b91a95361359e49494b4ed88701 Mon Sep 17 00:00:00 2001
+From: Bastian Kleineidam <bastian.kleineidam@web.de>
+Date: Tue, 10 Dec 2013 20:56:26 +0100
+Subject: [PATCH] Check for help files.
+
+---
+ linkcheck/configuration/__init__.py | 6 ++++--
+ 2 files changed, 6 insertions(+), 2 deletions(-)
+
+diff --git a/linkcheck/configuration/__init__.py b/linkcheck/configuration/__init__.py
+index 3b72499..f40f285 100644
+--- a/linkcheck/configuration/__init__.py
++++ b/linkcheck/configuration/__init__.py
+@@ -96,7 +96,8 @@ def get_share_file (devel_dir, filename):
+ @param filename: filename to search for
+ @ptype filename: string
+ @return: the found filename or None
+- @rtype: string or None
++ @rtype: string
++ @raises: ValueError if not found
+ """
+ paths = [
+ # when developing
+@@ -112,7 +113,8 @@ def get_share_file (devel_dir, filename):
+ if os.path.isfile(fullpath):
+ return fullpath
+ # not found
+- return None
++ msg = "%s not found in %s; check your installation" % (filename, paths)
++ raise ValueError(msg)
+
+
+ # dynamic options
+--
+1.8.5.1
+
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch b/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch
new file mode 100644
index 000000000000..598f856b0007
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-9.2-unbundle.patch
@@ -0,0 +1,30 @@
+ setup.py | 7 -------
+ 1 file changed, 7 deletions(-)
+
+diff --git a/setup.py b/setup.py
+old mode 100755
+new mode 100644
+index dc30a7d..d62622b
+--- a/setup.py
++++ b/setup.py
+@@ -900,9 +900,6 @@ o a command line, GUI and web interface
+ 'py2exe': MyPy2exe,
+ 'py2app': MyPy2app,
+ },
+- package_dir = {
+- 'linkcheck_dns.dns': 'third_party/dnspython/dns',
+- },
+ packages = [
+ 'linkcheck',
+ 'linkcheck.bookmarks',
+@@ -917,10 +914,6 @@ o a command line, GUI and web interface
+ 'linkcheck.network',
+ 'linkcheck.parser',
+ 'linkcheck.plugins',
+- 'linkcheck_dns.dns',
+- 'linkcheck_dns.dns.rdtypes',
+- 'linkcheck_dns.dns.rdtypes.ANY',
+- 'linkcheck_dns.dns.rdtypes.IN',
+ ],
+ ext_modules = [
+ Extension('linkcheck.HtmlParser.htmlsax',
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.3-bash-completion.patch b/net-analyzer/linkchecker/files/linkchecker-9.3-bash-completion.patch
new file mode 100644
index 000000000000..5c7540f0bc85
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-9.3-bash-completion.patch
@@ -0,0 +1,21 @@
+ config/linkchecker-completion | 3 +--
+ 1 file changed, 1 insertion(+), 2 deletions(-)
+
+diff --git a/config/linkchecker-completion b/config/linkchecker-completion
+index 5252b3b..0ea3b21 100644
+--- a/config/linkchecker-completion
++++ b/config/linkchecker-completion
+@@ -2,7 +2,6 @@
+ # Debian Linux system. For other system read the documentation that
+ # comes with the bash-completion package.
+
+-have linkchecker &&
+ _linkcheck() {
+ local cur prev
+
+@@ -17,4 +16,4 @@ _linkcheck() {
+ fi
+ return 0
+ }
+-[ "$have" ] && complete $filenames -F _linkcheck linkchecker
++complete $filenames -F _linkcheck linkchecker
diff --git a/net-analyzer/linkchecker/files/linkchecker-9.3-desktop.patch b/net-analyzer/linkchecker/files/linkchecker-9.3-desktop.patch
new file mode 100644
index 000000000000..40fa18a45983
--- /dev/null
+++ b/net-analyzer/linkchecker/files/linkchecker-9.3-desktop.patch
@@ -0,0 +1,34 @@
+From c25bdb3f55a791bfa087fb5a3d8e3d5d62991745 Mon Sep 17 00:00:00 2001
+From: Christopher Meng <cickumqt@gmail.com>
+Date: Fri, 10 Jan 2014 19:57:47 +0800
+Subject: [PATCH] Fix non-standard deskop file
+
+desktop-file-validate /home/rpmaker/rpmbuild/BUILDROOT/linkchecker-8.6-1.fc21.i386/usr/share/applications/linkchecker-gui.desktop /home/rpmaker/rpmbuild/BUILDROOT/linkchecker-8.6-1.fc21.i386/usr/share/applications/linkchecker.desktop
+/home/rpmaker/rpmbuild/BUILDROOT/linkchecker-8.6-1.fc21.i386/usr/share/applications/linkchecker-gui.desktop: error: value "Network;WebDevelopment" for string list key "Categories" in group "Desktop Entry" does not have a semicolon (';') as trailing character
+/home/rpmaker/rpmbuild/BUILDROOT/linkchecker-8.6-1.fc21.i386/usr/share/applications/linkchecker.desktop: error: value "True" for boolean key "Terminal" in group "Desktop Entry" contains invalid characters, boolean values must be "false" or "true"
+/home/rpmaker/rpmbuild/BUILDROOT/linkchecker-8.6-1.fc21.i386/usr/share/applications/linkchecker.desktop: error: value "Network;WebDevelopment" for string list key "Categories" in group "Desktop Entry" does not have a semicolon (';') as trailing character
+---
+ doc/linkchecker-gui.desktop | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/doc/linkchecker-gui.desktop b/doc/linkchecker-gui.desktop
+index 7e06b6e..09bd997 100644
+--- a/doc/linkchecker-gui.desktop
++++ b/doc/linkchecker-gui.desktop
+@@ -1,10 +1,10 @@
+ [Desktop Entry]
+-Name=LinkChecker GUI
++Name=LinkChecker GUI
+ GenericName=URL validator
+ GenericName[de]=URL Validator
+ Version=1.0
+ Type=Application
+ Exec=linkchecker-gui
+ Terminal=false
+-Categories=Network;WebDevelopment;
+-Icon=logo48x48
++Categories=Network;WebDevelopment;
++Icon=linkchecker
+--
+1.8.5.1
+