summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/hsc/hsc-1.0b.ebuild')
-rw-r--r--net-misc/hsc/hsc-1.0b.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-misc/hsc/hsc-1.0b.ebuild b/net-misc/hsc/hsc-1.0b.ebuild
new file mode 100644
index 000000000000..826d2d40d116
--- /dev/null
+++ b/net-misc/hsc/hsc-1.0b.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="An HTML preprocessor using ML syntax"
+HOMEPAGE="http://www.linguistik.uni-erlangen.de/~msbethke/software.html"
+SRC_URI="http://www.linguistik.uni-erlangen.de/~msbethke/binaries/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}-${PV/b/}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-cflags.patch"
+ epatch "${FILESDIR}/${P}-nostrip.patch"
+ epatch "${FILESDIR}/${P}-parmake.patch"
+ epatch "${FILESDIR}"/${P}-glibc-2.10.patch
+ eautoreconf
+}
+
+src_install() {
+ dodir /usr/share/hsc
+ emake BINDIR="${D}/usr/bin" DATADIR="${D}/usr/share/hsc" \
+ prefix="${D}/usr" docdir="${D}/usr/share/doc/${PF}" \
+ datadir="${D}/usr/share/hsc" install || die "make install failed"
+}