summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-block/endpoint')
-rw-r--r--sys-block/endpoint/Manifest1
-rw-r--r--sys-block/endpoint/endpoint-0.1.0.ebuild31
-rw-r--r--sys-block/endpoint/files/endpoint-0.1.0-errormessages.patch47
-rw-r--r--sys-block/endpoint/metadata.xml12
4 files changed, 91 insertions, 0 deletions
diff --git a/sys-block/endpoint/Manifest b/sys-block/endpoint/Manifest
new file mode 100644
index 000000000000..d691d35c927f
--- /dev/null
+++ b/sys-block/endpoint/Manifest
@@ -0,0 +1 @@
+DIST endpoint-0.1.0.tar.gz 121954 SHA256 53831b97f831dabd5694364d06b8ad2f33d1e73ab03f6c57bea3ad96fa7f510a
diff --git a/sys-block/endpoint/endpoint-0.1.0.ebuild b/sys-block/endpoint/endpoint-0.1.0.ebuild
new file mode 100644
index 000000000000..ddb5955e24ac
--- /dev/null
+++ b/sys-block/endpoint/endpoint-0.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Endpoint turns a Linux machine with one or more firewire cards into an SBP-2 device"
+HOMEPAGE="http://oss.oracle.com/projects/endpoint/"
+SRC_URI="http://oss.oracle.com/projects/endpoint/dist/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND=">=sys-libs/libraw1394-0.9
+ >=dev-libs/glib-2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ epatch "${FILESDIR}"/${P}-errormessages.patch
+}
+
+src_install() {
+ emake -j1 install DESTDIR="${D}"
+ insinto /etc
+ newins docs/sample-endpoint.conf endpoint.conf
+ dodoc README AUTHORS ChangeLog
+}
diff --git a/sys-block/endpoint/files/endpoint-0.1.0-errormessages.patch b/sys-block/endpoint/files/endpoint-0.1.0-errormessages.patch
new file mode 100644
index 000000000000..17926bc70574
--- /dev/null
+++ b/sys-block/endpoint/files/endpoint-0.1.0-errormessages.patch
@@ -0,0 +1,47 @@
+diff -Naur endpoint-0.1.0/libjconfig/jconfig.c endpoint-0.1.0.new/libjconfig/jconfig.c
+--- endpoint-0.1.0/libjconfig/jconfig.c 2003-10-13 15:21:12.000000000 -0700
++++ endpoint-0.1.0.new/libjconfig/jconfig.c 2006-02-26 23:48:58.000000000 -0800
+@@ -1242,9 +1242,12 @@
+ cfc = j_config_new_context();
+ if (cfc)
+ {
++ j_config_context_set_verbose(cfc,TRUE);
+ cf = j_config_parse_file_with_context(cfc, filename);
+ j_config_context_free(cfc);
+- }
++ } else {
++ g_warning("Failed to get config context.\n");
++ }
+
+ return(cf);
+ } /* j_config_parse_file() */
+diff -Naur endpoint-0.1.0/src/main.c endpoint-0.1.0.new/src/main.c
+--- endpoint-0.1.0/src/main.c 2003-10-13 15:21:14.000000000 -0700
++++ endpoint-0.1.0.new/src/main.c 2006-02-26 23:44:42.000000000 -0800
+@@ -133,7 +133,7 @@
+
+ if (!app)
+ {
+- /* ERROR MESSAGE */
++ fprintf(stderr,"Failed to parse config file %s.\n",configfile);
+ exit (1);
+ }
+
+@@ -142,7 +142,7 @@
+
+ if (app->ps_len < strlen (MASTER_NAME))
+ {
+- /* ERROR MESSAGE */
++ fprintf(stderr,"Failed strlen(MASTER_NAME).\n");
+ exit (1);
+ }
+
+@@ -152,7 +152,7 @@
+
+ if (!wire_init ())
+ {
+- /* ERROR MESSAGE */
++ fprintf(stderr,"Failed wire_init.\n");
+ exit (1);
+ }
+
diff --git a/sys-block/endpoint/metadata.xml b/sys-block/endpoint/metadata.xml
new file mode 100644
index 000000000000..4272e6c8f629
--- /dev/null
+++ b/sys-block/endpoint/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+ <longdescription lang="en">
+ Endpoint turns a Linux machine with one or more firewire cards into an SBP-2
+ device. The advantage is that you can use any file or device the linux
+ machine supports as storage, and that multiple clients can sit on separate
+ buses so they can get the full bandwidth of the bus.
+ </longdescription>
+</pkgmetadata>
+