summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild')
-rw-r--r--sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild b/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild
new file mode 100644
index 000000000000..55d26c0ef78a
--- /dev/null
+++ b/sys-boot/cromwell-bin/cromwell-bin-2.40.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit mount-boot
+
+IUSE=""
+DESCRIPTION="Xbox boot loader precompiled binaries from xbox-linux.org"
+SRC_URI="mirror://sourceforge/xbox-linux/cromwell-${PV}.tar.gz"
+HOMEPAGE="http://www.xbox-linux.org"
+RESTRICT="${RESTRICT} strip"
+DEPEND=""
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="-* x86"
+
+S=${WORKDIR}/cromwell-${PV}
+
+src_install () {
+ dodir /boot/${PN}
+ insinto /boot/${PN}
+ doins ${S}/cromwell.bin ${S}/cromwell_1024.bin ${S}/xromwell.xbe || die
+}