summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild b/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild
new file mode 100644
index 000000000000..aa82876c7993
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.11.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="User-space application to modify the EFI boot manager"
+HOMEPAGE="https://github.com/vathpela/efibootmgr"
+SRC_URI="https://github.com/vathpela/${PN}/releases/download/${P}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils
+ sys-libs/efivar"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e s/-Werror// Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+ export EXTRA_CFLAGS=${CFLAGS}
+}
+
+src_install() {
+ # build system uses perl, so just do it ourselves
+ dosbin src/efibootmgr/efibootmgr
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS README doc/ChangeLog doc/TODO
+}