summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild')
-rw-r--r--sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
new file mode 100644
index 000000000000..7e7ad853c8ce
--- /dev/null
+++ b/sys-boot/efibootmgr/efibootmgr-0.5.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Interact with the EFI Boot Manager"
+HOMEPAGE="http://developer.intel.com/technology/efi"
+SRC_URI="http://linux.dell.com/efibootmgr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ia64 ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/pciutils"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^LIBS/s:=.*:=$($(tc-getPKG_CONFIG) libpci --libs):" \
+ src/efibootmgr/module.mk || die
+}
+
+src_compile() {
+ strip-flags
+ tc-export CC
+ emake EXTRA_CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ # build system uses perl, so just do it ourselves
+ dosbin src/efibootmgr/efibootmgr || die
+ doman src/man/man8/efibootmgr.8
+ dodoc AUTHORS README doc/ChangeLog doc/TODO
+}