summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-themes/greybird/greybird-9999.ebuild')
-rw-r--r--x11-themes/greybird/greybird-9999.ebuild17
1 files changed, 10 insertions, 7 deletions
diff --git a/x11-themes/greybird/greybird-9999.ebuild b/x11-themes/greybird/greybird-9999.ebuild
index 395fa8e0a143..5c63ed8b7137 100644
--- a/x11-themes/greybird/greybird-9999.ebuild
+++ b/x11-themes/greybird/greybird-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools git-r3
MY_PN=${PN/g/G}
@@ -14,28 +14,31 @@ EGIT_REPO_URI="https://github.com/shimmerproject/${MY_PN}"
LICENSE="CC-BY-SA-3.0 GPL-2+"
SLOT="0"
KEYWORDS=""
-IUSE="ayatana gnome"
+IUSE="ayatana gnome xfce"
RDEPEND="
>=x11-libs/gtk+-3.22:3
>=x11-themes/gtk-engines-murrine-0.90
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
+ dev-lang/sassc
dev-libs/glib:2
dev-ruby/sass:3.5
"
src_prepare() {
- eapply_user
+ default
eautoreconf
}
src_install() {
- emake DESTDIR="${D}" install
+ default
- pushd "${ED}"usr/share/themes/${MY_PN} > /dev/null || die
+ pushd "${ED}"/usr/share/themes/${MY_PN} > /dev/null || die
use ayatana || rm -rf unity
use gnome || rm -rf metacity-1
+ use xfce || rm -rf xfce* xfwm4*
popd > /dev/null || die
}