summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-wm/larswm')
-rw-r--r--x11-wm/larswm/Manifest1
-rw-r--r--x11-wm/larswm/files/larswm.desktop7
-rw-r--r--x11-wm/larswm/larswm-7.5.3-r1.ebuild55
-rw-r--r--x11-wm/larswm/metadata.xml13
4 files changed, 76 insertions, 0 deletions
diff --git a/x11-wm/larswm/Manifest b/x11-wm/larswm/Manifest
new file mode 100644
index 000000000000..a269ecffe5ab
--- /dev/null
+++ b/x11-wm/larswm/Manifest
@@ -0,0 +1 @@
+DIST larswm-7.5.3.tar.gz 84505 SHA256 7b444b10a93589cbdb4ff45a785d5a65121d80f27a73f0b2ec74421b5eeab4f6
diff --git a/x11-wm/larswm/files/larswm.desktop b/x11-wm/larswm/files/larswm.desktop
new file mode 100644
index 000000000000..6be965d27308
--- /dev/null
+++ b/x11-wm/larswm/files/larswm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Version=1.0
+Name=larswm
+Comment=This session logs you into larswm
+Exec=larswm-session
+Icon=
+Type=Application
diff --git a/x11-wm/larswm/larswm-7.5.3-r1.ebuild b/x11-wm/larswm/larswm-7.5.3-r1.ebuild
new file mode 100644
index 000000000000..e3466a5dd12a
--- /dev/null
+++ b/x11-wm/larswm/larswm-7.5.3-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tiling window manager for X11, based on 9wm by David Hogan"
+HOMEPAGE="http://larswm.fnurt.net/"
+SRC_URI="http://larswm.fnurt.net/${P}.tar.gz"
+LICENSE="9wm"
+
+SLOT="0"
+KEYWORDS="alpha ~amd64 ppc ppc64 x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto
+ x11-misc/imake
+ x11-misc/gccmakedep
+ app-text/rman"
+
+src_configure() {
+ xmkmf -a || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}" \
+ || die
+}
+
+src_install() {
+ dobin larsclock larsmenu larsremote larswm
+ newbin sample.xsession larswm-session
+ for x in *.man ; do
+ newman $x ${x/man/1}
+ done
+ dodoc ChangeLog README* sample.*
+
+ insinto /etc/X11
+ newins sample.larswmrc larswmrc || die
+ exeinto /etc/X11/Sessions
+ newexe sample.xsession larswm
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/larswm.desktop || die
+}
diff --git a/x11-wm/larswm/metadata.xml b/x11-wm/larswm/metadata.xml
new file mode 100644
index 000000000000..4ac6c58c9045
--- /dev/null
+++ b/x11-wm/larswm/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
+ <longdescription>
+ larswm is a modified version of the 9wm window manager that adds virtual
+ desktops, automatic window tiling, and many other features designed to
+ make it a highly efficient user environment. One of the design goals is
+ that you should never have to manually shuffle windows around on the
+ screen. Another is that it should use as little CPU time, RAM, and screen
+ space for itself as possible.
+ </longdescription>
+</pkgmetadata>