summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2006-05-23 19:01:07 +0000
committerSven Wegener <swegener@gentoo.org>2006-05-23 19:01:07 +0000
commit1b402022458d0ab541d6f987f703cc1b47836a72 (patch)
tree6b8915f1e3858553fde4d6ab6e8f8aaf0fc2713a
parentStable on ppc64; bug #133989 (diff)
downloadhistorical-1b402022458d0ab541d6f987f703cc1b47836a72.tar.gz
historical-1b402022458d0ab541d6f987f703cc1b47836a72.tar.bz2
historical-1b402022458d0ab541d6f987f703cc1b47836a72.zip
Version bump.
Package-Manager: portage-2.1_rc2
-rw-r--r--net-dns/pdns-recursor/ChangeLog8
-rw-r--r--net-dns/pdns-recursor/files/digest-pdns-recursor-3.13
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-3.1.ebuild32
3 files changed, 42 insertions, 1 deletions
diff --git a/net-dns/pdns-recursor/ChangeLog b/net-dns/pdns-recursor/ChangeLog
index 42b52277f8ce..f117d6dc67d8 100644
--- a/net-dns/pdns-recursor/ChangeLog
+++ b/net-dns/pdns-recursor/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dns/pdns-recursor
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.2 2006/04/30 20:56:14 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/ChangeLog,v 1.3 2006/05/23 19:01:07 swegener Exp $
+
+*pdns-recursor-3.1 (23 May 2006)
+
+ 23 May 2006; Sven Wegener <swegener@gentoo.org>
+ -pdns-recursor-3.0.1.ebuild, +pdns-recursor-3.1.ebuild:
+ Version bump.
30 Apr 2006; Sven Wegener <swegener@gentoo.org> files/precursor:
Stop by pid until the rec_control quit code works with chroot enabled.
diff --git a/net-dns/pdns-recursor/files/digest-pdns-recursor-3.1 b/net-dns/pdns-recursor/files/digest-pdns-recursor-3.1
new file mode 100644
index 000000000000..109daecd588a
--- /dev/null
+++ b/net-dns/pdns-recursor/files/digest-pdns-recursor-3.1
@@ -0,0 +1,3 @@
+MD5 a3e0b0ced4933076ef6dae2cc856c4c5 pdns-recursor-3.1.tar.bz2 136940
+RMD160 40aa3de355a09491d15379adb7e8cf4660d04dc7 pdns-recursor-3.1.tar.bz2 136940
+SHA256 1eecae868a013364818336d48f73ce91be5a47896042ec95bb2ad755657f00be pdns-recursor-3.1.tar.bz2 136940
diff --git a/net-dns/pdns-recursor/pdns-recursor-3.1.ebuild b/net-dns/pdns-recursor/pdns-recursor-3.1.ebuild
new file mode 100644
index 000000000000..92f68a8f5ed1
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/pdns-recursor/pdns-recursor-3.1.ebuild,v 1.1 2006/05/23 19:01:07 swegener Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="http://www.powerdns.com/"
+SRC_URI="http://downloads.powerdns.com/releases/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=">=dev-libs/boost-1.33.1"
+RDEPEND="${DEPEND}
+ !net-dns/pdns"
+
+src_compile() {
+ emake CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die "emake failed"
+}
+
+src_install() {
+ dosbin pdns_recursor rec_control || die "dosbin failed"
+ doman pdns_recursor.1 rec_control.1 || die "doman failed"
+
+ insinto /etc/powerdns
+ doins "${FILESDIR}"/recursor.conf || die "doina failed"
+
+ doinitd "${FILESDIR}"/precursor || die "doinitd failed"
+}