summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-16 16:22:29 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-16 16:22:29 +0000
commit25848591e25bd9c524c36bcba06c383dfe868cab (patch)
tree2be9f17c64c091f3efaed869f7a3cfd68b2edc07
parentVersion bump. (diff)
downloadhistorical-25848591e25bd9c524c36bcba06c383dfe868cab.tar.gz
historical-25848591e25bd9c524c36bcba06c383dfe868cab.tar.bz2
historical-25848591e25bd9c524c36bcba06c383dfe868cab.zip
Delete older ebuilds.
-rw-r--r--dev-python/webhelpers/ChangeLog6
-rw-r--r--dev-python/webhelpers/webhelpers-0.6.4.ebuild35
-rw-r--r--dev-python/webhelpers/webhelpers-1.0.ebuild59
3 files changed, 5 insertions, 95 deletions
diff --git a/dev-python/webhelpers/ChangeLog b/dev-python/webhelpers/ChangeLog
index 3f8cbdcefd0c..6e1278387a5e 100644
--- a/dev-python/webhelpers/ChangeLog
+++ b/dev-python/webhelpers/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/webhelpers
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webhelpers/ChangeLog,v 1.10 2010/06/07 19:38:00 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/webhelpers/ChangeLog,v 1.11 2010/09/16 16:22:29 arfrever Exp $
+
+ 16 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -webhelpers-0.6.4.ebuild, -webhelpers-1.0.ebuild:
+ Delete.
*webhelpers-1.0 (07 Jun 2010)
diff --git a/dev-python/webhelpers/webhelpers-0.6.4.ebuild b/dev-python/webhelpers/webhelpers-0.6.4.ebuild
deleted file mode 100644
index d957db248764..000000000000
--- a/dev-python/webhelpers/webhelpers-0.6.4.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webhelpers/webhelpers-0.6.4.ebuild,v 1.4 2009/12/29 21:37:44 arfrever Exp $
-
-EAPI="2"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils
-
-MY_PN="WebHelpers"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="A library of helper functions intended to make writing templates in web applications easier."
-HOMEPAGE="http://pylonshq.com/docs/en/0.9.7/thirdparty/webhelpers/ http://pypi.python.org/pypi/WebHelpers"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="test"
-
-RDEPEND=">=dev-python/routes-1.8"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? ( dev-python/nose dev-python/coverage )"
-RESTRICT_PYTHON_ABIS="3.*"
-
-S="${WORKDIR}/${MY_P}"
-
-src_test() {
- testing() {
- PYTHONPATH="build-${PYTHON_ABI}/lib" nosetests-${PYTHON_ABI}
- }
- python_execute_function testing
-}
diff --git a/dev-python/webhelpers/webhelpers-1.0.ebuild b/dev-python/webhelpers/webhelpers-1.0.ebuild
deleted file mode 100644
index f39af374fa6c..000000000000
--- a/dev-python/webhelpers/webhelpers-1.0.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/webhelpers/webhelpers-1.0.ebuild,v 1.1 2010/06/07 19:38:00 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-DISTUTILS_SRC_TEST="nosetests"
-
-inherit distutils
-
-MY_PN="WebHelpers"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Web Helpers"
-HOMEPAGE="http://webhelpers.groovie.org/ http://pypi.python.org/pypi/WebHelpers"
-SRC_URI="http://pypi.python.org/packages/source/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="doc"
-
-RDEPEND="dev-python/routes"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- doc? ( dev-python/sphinx )"
-
-S="${WORKDIR}/${MY_P}"
-
-src_prepare() {
- distutils_src_prepare
-
- sed \
- -e '/import datetime/a import os' \
- -e 's:"/tmp/feed":os.environ.get("TMPDIR", "/tmp") + "/feed":' \
- -i tests/test_feedgenerator.py || die "sed failed"
-}
-
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- einfo "Generation of documentation"
- cd docs
- ./build || die "Generation of documentation failed"
- fi
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- cd docs/_build/html
- docinto html
- cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
- fi
-}