summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-07-20 04:07:43 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-07-20 04:07:43 +0000
commit370d5aaeb9fe6f0fa84cc49ccf9dcbc807e86ff0 (patch)
tree0f3446900f65403be8f6ae4c894de3eb2910b42e
parentinital commit (diff)
downloadhistorical-370d5aaeb9fe6f0fa84cc49ccf9dcbc807e86ff0.tar.gz
historical-370d5aaeb9fe6f0fa84cc49ccf9dcbc807e86ff0.tar.bz2
historical-370d5aaeb9fe6f0fa84cc49ccf9dcbc807e86ff0.zip
inital commit
-rw-r--r--sys-apps/nictools/Manifest4
-rw-r--r--sys-apps/nictools/files/digest-nictools-200307191
-rw-r--r--sys-apps/nictools/nictools-20030719.ebuild59
3 files changed, 62 insertions, 2 deletions
diff --git a/sys-apps/nictools/Manifest b/sys-apps/nictools/Manifest
index 871cf949bdd0..ebd17076bac5 100644
--- a/sys-apps/nictools/Manifest
+++ b/sys-apps/nictools/Manifest
@@ -1,3 +1,3 @@
-MD5 9b5c4519049e02019508793782609356 nictools-20030719.ebuild 1835
-MD5 99006529bbe06e04898406f36893aaad ChangeLog 358
+MD5 182175018cb64be3f56c9552d1973b5f nictools-20030719.ebuild 1833
+MD5 2ae688680d21a7179241a573e37e9019 ChangeLog 393
MD5 c6c7fffb17e5b59f0b920a3e44f0406e files/digest-nictools-20030719 67
diff --git a/sys-apps/nictools/files/digest-nictools-20030719 b/sys-apps/nictools/files/digest-nictools-20030719
new file mode 100644
index 000000000000..2a6fcedf5cdc
--- /dev/null
+++ b/sys-apps/nictools/files/digest-nictools-20030719
@@ -0,0 +1 @@
+MD5 af92d4c7d5c8d6b12cd7ff9148f89ae6 nictools-20030719.tbz2 110252
diff --git a/sys-apps/nictools/nictools-20030719.ebuild b/sys-apps/nictools/nictools-20030719.ebuild
new file mode 100644
index 000000000000..d238f50abf0e
--- /dev/null
+++ b/sys-apps/nictools/nictools-20030719.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/nictools/nictools-20030719.ebuild,v 1.1 2003/07/20 04:07:37 robbat2 Exp $
+
+DESCRIPTION="nictools - diagnostic tools for a variety of ISA and PCI network cards"
+HOMEPAGE="http://www.scyld.com/diag/index.html"
+# The tarball is a slightly modified version compiled of the _latest_ versions
+# of the files from all of the debian package, and the entirely of the Scyld
+# website.
+# It has a vastly modified Makefile to make it easy to build on Gentoo
+SRC_URI="mirrors:/gentoo/${P}.tbz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="static"
+DEPEND=""
+
+S=${WORKDIR}/${P}
+
+nictools_grabvar() {
+ gmake VAR="${1}" printvar
+}
+
+nictools_setupcards() {
+ if [ -z "${NICTOOLS_CARDS}" ]; then
+ NICTOOLS_CARDS="pci isa"
+ fi
+ for card in ${NICTOOLS_CARDS}; do
+ UPPER=`echo ${card} | tr '[:lower:]' '[:upper:]'`
+ NICTOOLS_INSTALL="${NICTOOLS_INSTALL} `nictools_grabvar ${UPPER}`"
+ NICTOOLS_INSTALL="${NICTOOLS_INSTALL} `nictools_grabvar ${card}`"
+ done
+ NICTOOLS_INSTALL="${NICTOOLS_INSTALL} `nictools_grabvar UTILS`"
+ NICTOOLS_INSTALL="`echo ${NICTOOLS_INSTALL} | xargs -n1 | sort | uniq |xargs`"
+}
+
+pkg_setup() {
+ einfo "If you want the configuration tools for only PCI or ISA cards, "
+ einfo "do: 'NICTOOLS_CARDS=\"pci\" emerge nictools' or 'NICTOOLS_CARDS=\"isa\" emerge nictools'"
+}
+
+src_compile() {
+ nictools_setupcards
+ use static && CFLAGS="${CFLAGS} -static"
+ emake ${NICTOOLS_INSTALL} || die "emake failed"
+}
+
+src_install() {
+ nictools_setupcards
+ # we do this as the user might not have /usr mounted and they might want
+ # the tool to configure the network card so they can use it!
+ into /
+ for i in ${NICTOOLS_INSTALL}; do
+ dosbin ${i}
+ done
+ into /usr
+ doman netdiag.8
+}
+