summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeth Chandler <sethbc@gentoo.org>2003-03-24 21:37:51 +0000
committerSeth Chandler <sethbc@gentoo.org>2003-03-24 21:37:51 +0000
commit38fb7fe531baecaff1af590315a30442a2ace0de (patch)
tree1d2326b8fdc14492e56f865f69ab634b1daada60
parentTry to fix corner cases where we get libstdc++.so not found problems (diff)
downloadhistorical-38fb7fe531baecaff1af590315a30442a2ace0de.tar.gz
historical-38fb7fe531baecaff1af590315a30442a2ace0de.tar.bz2
historical-38fb7fe531baecaff1af590315a30442a2ace0de.zip
made a few changes to some gnome scripts...
-rw-r--r--app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild10
-rw-r--r--app-office/openoffice/openoffice-1.0.2.ebuild5
2 files changed, 11 insertions, 4 deletions
diff --git a/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild b/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild
index 6c02e952d8ef..2d75461781aa 100644
--- a/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild
+++ b/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild,v 1.10 2003/03/19 05:30:37 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice-bin/openoffice-bin-1.0.2.ebuild,v 1.11 2003/03/24 21:37:51 sethbc Exp $
IUSE="kde gnome"
@@ -35,7 +35,8 @@ DEPEND="virtual/glibc
app-arch/zip
app-arch/unzip
>=virtual/jdk-1.3.1
- !app-office/openoffice"
+ !app-office/openoffice
+ virtual/lpr"
LICENSE="LGPL-2 | SISSL-1.1"
SLOT="0"
@@ -179,6 +180,11 @@ src_install() {
# Unneeded, as they get installed into /usr/share...
rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
+ for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
+ echo 'Categories=Application;Office;' >> ${f}
+ done
+
+
# Make sure these do not get nuked.
keepdir ${INSTDIR}/user/config/registry/instance/org/openoffice/{Office,ucb}
keepdir ${INSTDIR}/user/psprint/{driver,fontmetric}
diff --git a/app-office/openoffice/openoffice-1.0.2.ebuild b/app-office/openoffice/openoffice-1.0.2.ebuild
index 687c07b88e84..143b0fd52efd 100644
--- a/app-office/openoffice/openoffice-1.0.2.ebuild
+++ b/app-office/openoffice/openoffice-1.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.2.ebuild,v 1.14 2003/03/20 04:50:26 sethbc Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/openoffice/openoffice-1.0.2.ebuild,v 1.15 2003/03/24 21:37:51 sethbc Exp $
# IMPORTANT: This is extremely alpha!!!
@@ -74,6 +74,7 @@ RDEPEND=">=sys-libs/glibc-2.1
app-arch/unzip
dev-libs/expat
>=virtual/jdk-1.3.1
+ virtual/lpr
ppc? ( >=sys-libs/glibc-2.2.5-r7
>=sys-devel/gcc-3.2 )" # needed for sqrtl patch recently introduced
@@ -549,7 +550,7 @@ src_install() {
# Unneeded, as they get installed into /usr/share...
rm -rf ${D}${INSTDIR}/share/{cde,gnome,kde}
- for f in ${D}/usr/share/gnome/apps/OpenOffice.org/ ; do
+ for f in ${D}/usr/share/gnome/apps/OpenOffice.org/* ; do
echo 'Categories=Application;Office;' >> ${f}
done